Unit Test Runner ?

Answered

Just started using resharper for unit testing with VS 2015 and xunit. 

Versions:

Resharper: 2016.1.2

VS Ultimate 2015: Update 3

XUnit : 2.1.0

 

When i setup a test with xunit with a "theory" and which includes a variety of data using "[InlineData("MyData")]" attribute and then for whatever reason i remove some of the inline data this is the effect i get:

 

 

The blue ? along with a strikethrough through the tests i removed. This of course is not what i want. If i remove inline data for the test i don't want to see it anymore. I tried to create a new session and tried to delete the tests through the toolbar but the only way i've been able to clear them is to close visual studio and reopen. Is this a bug or how things work? How can i fix the issue?

2 comments
Comment actions Permalink
Official comment

Hello Brent,

Please install R# 2016.2 RC https://confluence.jetbrains.com/display/ReSharper/ReSharper+2016.2+EAP and check the issue once again.

Thanks! 

Comment actions Permalink

Ok i found out that the first time i run after the specific includedata is deleted this is what i'll see:

The 2nd time or anytime after i'll see what i posted above. The tests will say "Inconclusive: Test not run."

0

Please sign in to leave a comment.