Resharper is slow and takes several minutes to start. Need way to disable Caching.

Since upgrading to VS2015, Resharper is unbearably slow and the culprit seems to be caching.  On every launch if I don't run the .bat file commands below I have to sit through several minutes of "Updating Sources".  If I clear those caches before launching, everything starts right up.  Visual Studio will remain fast for about 2 hours before I have to restart and clear caches again or suspend Resharper, clear caches, and resume it. 

I believe the Caching system is just broken and it'd be nice to disable it all together. 

set "pathtofolder=C:\ProgramData\JetBrains\Resharper\SolutionCaches\"
echo %pathtofolder%
dir /s %pathtofolder% | grep --after-context=1 "Total Files Listed:"
pushd "%pathtofolder%" && (rd /s /q "%pathtofolder%" 2>nul & popd)

 

Please sign in to leave a comment.