Could not run the 'C:\Program....\CSharpAddClass.vsz' wizard.

I am now getting this error when I try to add a class to my project. Everything was fine while I was running build 86. Now with build 89 I'm getting this error which is pretty much a show stopper. I tried uninstalling but I still get the error.

Hopefully I don't have to reinstall VS again...

4 comments
Comment actions Permalink

This is a known problem with uninstall of R#.

Check this page for the solution:
http://www.jetbrains.net/confluence/display/ReSharper/InstallationProblemsWorkaround

P.S.: BTW, you don't have to uninstall R# in order to install a new build.

0
Comment actions Permalink

Did you try the solution described on
http://www.jetbrains.net/confluence/display/ReSharper/InstallationProblemsWorkaround ?
The re-registering of csproj.dll should help.

--
Andrey Simanovsky
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"



"Bryant Likes" <no_mail@jetbrains.com> wrote in message
news:31233469.1088184136176.JavaMail.itn@is.intellij.net...

I am now getting this error when I try to add a class to my project.

Everything was fine while I was running build 86. Now with build 89 I'm
getting this error which is pretty much a show stopper. I tried uninstalling
but I still get the error.
>

Hopefully I don't have to reinstall VS again...



0
Comment actions Permalink

I already ran a repair on VS.Net so hopefully that issue will be fixed.

However, now I'm getting a new error in my favorite feature "Tip of the Day":

IOException: The process cannot access the file "NextPrevError.html" because it is being used by another process.

So I can't close the tip :) Maybe you should allow the user to select the Tip of the Day in the install since this "feature" is causing a lot headaches.

0
Comment actions Permalink

Ok I've gotten around the IOException problem (it seems there was a hidden dialog that I missed), but now I have a much more serious problem.

When I try to open a web form I get the following exception:

The file could not be loaded into the Web Forms designer. Please correct the following error and then try loading it again:

Exception from HRESULT: 0x800700C1.

Make sure all of the classes used in the page are built or referenced in the project. Click Help for more information.

This error is showing up when I just open any web form. Any ideas? I tried the re-reg csproj.dll but that didn't help. Is there something else I need to re-reg?

0

Please sign in to leave a comment.