[VS2003 v205] Test Runner Broken?

I just installed v205, after un-installing v204. When I run any NUnit test,
I get this exception:

-


UnitTestRunner
-


System.Net.Sockets.SocketException: No connection could be made because the
target machine actively refused it


Server stack trace:
at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)

at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket()

at System.Runtime.Remoting.Channels.SocketCache.GetSocket(String
machineAndPort)

at
System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.SendRequestWithRetry(IMessage
msg, ITransportHeaders requestHeaders, Stream requestStream)

at
System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage(IMessage
msg, ITransportHeaders requestHeaders, Stream requestStream,
ITransportHeaders& responseHeaders, Stream& responseStream)

at
System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage
msg)

Exception rethrown at :
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage
reqMsg, IMessage retMsg)

at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData&
msgData, Int32 type)

at
JetBrains.ReSharper.UnitTestSupport.PluginInterface.ITestListener.OnFixtureStartup(String
runnerId, String assemblyName, String fixtureName)

at
JetBrains.ReSharper.UnitTestSupport.Plugin.UnitFixture.Run(ITestMethod[]
methodsToRun, Boolean[] explicitFlags) in
c:\TEMP\tmp601E.tmp\src\UnitTestSupport\src\Plugin\UnitFixture.cs:line 104

at JetBrains.ReSharper.UnitTestSupport.Plugin.UnitFixture.Run(String[]
methodNames, Boolean[] explicitFlags) in
c:\TEMP\tmp601E.tmp\src\UnitTestSupport\src\Plugin\UnitFixture.cs:line 89

at
System.Runtime.Remoting.Messaging.StackBuilderSink.PrivateProcessMessage(MethodBase
mb, Object[] args, Object server, Int32 methodPtr, Boolean
fExecuteInContext, Object[]& outArgs)

at
System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage
msg, Int32 methodPtr, Boolean fExecuteInContext)

Exception rethrown at :
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage
reqMsg, IMessage retMsg)

at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData&
msgData, Int32 type)

at
JetBrains.ReSharper.UnitTestSupport.PluginInterface.ITestFixture.Run(String[]
methodNames, Boolean[] explicitFlags)

at JetBrains.ReSharper.UnitTestSupport.Runner.TestRunner.Run(String[]
args) in
c:\TEMP\tmp601E.tmp\src\UnitTestSupport\src\TestRunner\TestRunner.cs:line
204
-


OK
-



I am using WinXP SP2 on VS2003 and never had this issue with v204. Has
anyone else seen this?

Thanks,
Derek


Please sign in to leave a comment.