Keyboard shortcuts reset on each Visual Studio start (R# 206 for Visual Studio 2003)

I copied keyboard scheme to a writable copy. R# properly updated this scheme
during install. However, after I further customized this scheme with MY shortcuts
(I remapped some R# commands), the customizations are lost on next Visual
Studio start.

I don't think you have the right to go behind your users backs and erase
their keyboard customizations.

HL


10 comments
Comment actions Permalink

Please note that when I make my "Resharper.vsk" file read-only (stores my
copy of Visual Studio keyboard schema), Visual Studio freezes during startup.
This confirms my suspicion that R# 2.0 for Visual Studio is resetting shortcuts
on every Visual Studio start.

Please at least add a flag that allows users to disable keyboard shortcuts
resetting during Visual Studio startup. The optimal solution of course would
be to reset shortcuts only when installing ReSharper and when the reset shortcuts
button is explicitely pressed by the user.

Thank you,
HL


0
Comment actions Permalink

In fact, R# should not rewrite shortcuts. I'll check it.

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Please, check your registry at
HKEY_CURRENT_USER\Software\JetBrains\ReSharper
key InitializationRequired. It should exist and equal to 0.

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Hello Sergey,

Please, check your registry at
HKEY_CURRENT_USER\Software\JetBrains\ReSharper
key InitializationRequired. It should exist and equal to 0.


I did. However HKCU did NOT have the key -> it was in HKLM (HKEY_LOCAL_MACHINE)
instead. The value was set to 1 (after many Visual Studio restarts). But
even when I explicitely set it to 0 the shortcuts were still reset on Visual
Studio startup (I tried it twice...).

HL

P.S. I just checked my registry for R# 165 and it has the InitializationRequired
DWORD set in local machine hive too, but it's properly set to 0 (build 165
(1.5 RC) does not reset my shortcuts) - did you mean HKLM in your post or
is something wrong with my machine?

P.P.S. I checked my colleague's machine (he still has 206 installed) and
he also has the value set to 1 after many Visual Studio starts + it's in
HKLM\Software\JetBrains\ReSharper\VSAddin2003 instead of the path you mentioned.


0
Comment actions Permalink

Same here... I have no such key under HKCU. It does exists under HKLM and
has the value of 1 (for VS2005). At the same time I have some earlier build
of Resharper (probably 202) installed for VS2003, and corresponding value
is 0!

Regards,
Maxim.


0
Comment actions Permalink

In the source code HKCU is used.

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Hello Sergey,

In the source code HKCU is used.


I hope you're saying this will be fixed in 207 ;).

Thanks,
HL


0
Comment actions Permalink

Absolutely.
As a temporary workaround add the key manually. I'm almost sure, it will
help.

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Please try to remove ReSharper and re-install it. This should help

0
Comment actions Permalink

Actually, it was a bug - this registry value was only updated in all-users
scenario (i.e. when it is in HKCU).
We've corrected it in 206.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Absolutely.
As a temporary workaround add the key manually. I'm almost sure, it
will
help.



0

Please sign in to leave a comment.