Build 207 is almost unuable for me -- anyone else?

My main problem is that I keep getting bugs like this that I submitted to the Tracker. It happens almost everytime I right click in the editor. It also happens every time I type an object name followed by '.'. It also happens with CTRL-space code completion.

I have cleared my Resharper cache hoping that would fix the problem but no luck. This was not a problem with 206. Maybe I will have to go back to 206.

- http://www.intellij.net/tracker/resharper/viewSCR?publicId=10640

13 comments
Comment actions Permalink

Please could you try to delete all ReSharper caches:
1) Close all VS instances
2) From your solution folder
3) System caches at
"C:\Documents and Settings\your name here...\Local Settings\Application
Data\JetBrains\"

And restart VS then.


--
Eugene Pasynkov
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"Kelly Summerlin" <no_mail@jetbrains.com> wrote in message
news:15648373.1127504655292.JavaMail.itn@is.intellij.net...

My main problem is that I keep getting bugs like this that I submitted
to the Tracker. It happens almost everytime I right click in the editor.
It also happens every time I type an object name followed by '.'. It also
happens with CTRL-space code completion.

>

I have cleared my Resharper cache hoping that would fix the problem but no
luck. This was not a problem with 206. Maybe I will have to go back to
206.

>

- http://www.intellij.net/tracker/resharper/viewSCR?publicId=10640



0
Comment actions Permalink

Hello Kelly,

The problem is that ReSharper failed to correctly process one of the referenced
assemblies (exception #8727 and others). As a result caches were saved with
invalid contents (exception #10633 etc), which in turn produces frequent
failures in program analysis (#10634 etc).
The problem is not specific to build 207. It might have one of the two origins.
It might be specific to a new assembly you have recently referenced. Alternatively,
it might be caused by "unlucky" (a logged in the tracker COM-and-message-pump
related bug in our code) re-build of the caches, which is done after ReSharper
is (re)installed. The latter seems to be the case (#8727).
To fix the problem you can reinstall build 207 (that will automatically invalidate
remaining caches), or clean caches manually.

My main problem is that I keep getting bugs like this that I
submitted to the Tracker. It happens almost everytime I right click in
the editor. It also happens every time I type an object name followed
by '.'. It also happens with CTRL-space code completion.

I have cleared my Resharper cache hoping that would fix the problem
but no luck. This was not a problem with 206. Maybe I will have to go
back to 206.

- http://www.intellij.net/tracker/resharper/viewSCR?publicId=10640

Thanks,
Andrey Simanovsky


0
Comment actions Permalink

Hello Kelly,

after clearing ReSharper caches, please also note the exception you get first
- it most likely
causes other exceptions. I see that you get #8726 - is it the first exception?

Thanks in advance.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello Kelly,

The problem is that ReSharper failed to correctly process one of the
referenced
assemblies (exception #8727 and others). As a result caches were saved
with
invalid contents (exception #10633 etc), which in turn produces
frequent
failures in program analysis (#10634 etc).
The problem is not specific to build 207. It might have one of the two
origins.
It might be specific to a new assembly you have recently referenced.
Alternatively,
it might be caused by "unlucky" (a logged in the tracker
COM-and-message-pump
related bug in our code) re-build of the caches, which is done after
ReSharper
is (re)installed. The latter seems to be the case (#8727).
To fix the problem you can reinstall build 207 (that will
automatically invalidate
remaining caches), or clean caches manually.

>> My main problem is that I keep getting bugs like this that I
>> submitted to the Tracker. It happens almost everytime I right click
>> in the editor. It also happens every time I type an object name
>> followed by '.'. It also happens with CTRL-space code completion.
>>
>> I have cleared my Resharper cache hoping that would fix the problem
>> but no luck. This was not a problem with 206. Maybe I will have to go
>> back to 206.
>>
>> -
>> http://www.intellij.net/tracker/resharper/viewSCR?publicId=10640
>>

Thanks,
Andrey Simanovsky



0
Comment actions Permalink

I uninstalled resharper and then reinstalled it. I opened the solution and I got no errors. Then I closed VS.Net and reopened the solution. The second time I open it, this is the first exception I get (see attachment).



Attachment(s):
firstexception.txt
0
Comment actions Permalink

Sorry, I didn't realize that attaching my file would post the message.

Anyway. After that exception I cannot use resharper without getting numerous other exceptions.

I guess I'm off to reinstall resharper again.

0
Comment actions Permalink

Hello Kelly,

could you please tell us what assemblies are referenced in your solution?
The problem is almost certainly in one of them.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Sorry, I didn't realize that attaching my file would post the message.

Anyway. After that exception I cannot use resharper without getting
numerous other exceptions.

I guess I'm off to reinstall resharper again.



0
Comment actions Permalink

Hello Kelly,

In build 208 that kind of situations will not lead to exceptions.
Thank you for the exception information you provided in your post. We will
try to figure out the problem library from it.

I uninstalled resharper and then reinstalled it. I opened the solution
and I got no errors. Then I closed VS.Net and reopened the solution.
The second time I open it, this is the first exception I get (see
attachment).

Thanks,
Andrey Simanovsky


0
Comment actions Permalink

This solution has about 11 projects in it which is actually pretty small for us. We usually have at least 25-30 projects in a solution. Mostly the projects consist of project references and references to the system assemblies. There is one web project as well as a web services project. The rest of the projects are just library assemblies used by the web service and/or the web project.

If you think it would be of great value, I might be able to spend some time and try and figure out the least set of projects that can reproduce the error. I might then be able to email you a zip with the solution, project files, and source.

This might take some time and I can't do it right now because I must get back to my real job. Again please let me know if this would help you. If you think that build 208 might alleviate some or all of this pain let me know that as well so I don't spin my wheels on it.

0
Comment actions Permalink

Hello Kelly,

your suggestion would be of immense help for us. Actually, the most interesting
thing is what third-party assemblies are referenced in your solution and
where can
we find them to check how ReSharper parses them. It is enough if you just
name them all
if they are publicly available.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

This solution has about 11 projects in it which is actually pretty
small for us. We usually have at least 25-30 projects in a solution.
Mostly the projects consist of project references and references to
the system assemblies. There is one web project as well as a web
services project. The rest of the projects are just library assemblies
used by the web service and/or the web project.

If you think it would be of great value, I might be able to spend some
time and try and figure out the least set of projects that can
reproduce the error. I might then be able to email you a zip with the
solution, project files, and source.

This might take some time and I can't do it right now because I must
get back to my real job. Again please let me know if this would help
you. If you think that build 208 might alleviate some or all of this
pain let me know that as well so I don't spin my wheels on it.



0
Comment actions Permalink

These are the only third party assemblies in my solution. I included the link to the ajax assembly because there a several of them around. The only thing not publicly available is the Xceed stuff from Xceed.com. I don't know if they have trials for those components or not.

When I get the opportunity I will try to reduce my solution down to the bare minimum.

Third party assemblies are:

ajax.dll
log4net.dll
Xceed.Compression.dll
Xceed.FileSystem.dll
Xceed.Zip.dll
Microsoft.Web.Services2
NHibernate.dll
Nullables.NHibernate.dll
Nullables.dll

- http://ajax.schwarz-interactive.de/csharpsample/default.aspx

0
Comment actions Permalink

Kelly,

so far I have had no luck repeating this issue. I created a simple
project and added references to all the components you mentioned
(in fact, I added all the assemblies from XCeed toolkit), but no exceptions
occurred. So I'm looking forware to a more detailed information or a sample
solution from you.

Thank you in advance.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

These are the only third party assemblies in my solution. I included
the link to the ajax assembly because there a several of them around.
The only thing not publicly available is the Xceed stuff from
Xceed.com. I don't know if they have trials for those components or
not.

When I get the opportunity I will try to reduce my solution down to
the bare minimum.

Third party assemblies are:

ajax.dll
log4net.dll
Xceed.Compression.dll
Xceed.FileSystem.dll
Xceed.Zip.dll
Microsoft.Web.Services2
NHibernate.dll
Nullables.NHibernate.dll
Nullables.dll
- http://ajax.schwarz-interactive.de/csharpsample/default.aspx



0
Comment actions Permalink

After posting here last time I have reinstalled resharper four times to get past this problem.

I completely forgot about it yesderday though because the problem did appear at all yesterday. I don't know what has changed in my solution recently, but suddenly I no longer get the errors I was getting before.

If it begins happening again, I will let you know.

0
Comment actions Permalink

Hello Kelly,

it's a pity that we lost track of the problem, but OK,
let's wait if it manifests itself again.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

After posting here last time I have reinstalled resharper four times
to get past this problem.

I completely forgot about it yesderday though because the problem did
appear at all yesterday. I don't know what has changed in my solution
recently, but suddenly I no longer get the errors I was getting
before.

If it begins happening again, I will let you know.



0

Please sign in to leave a comment.