[349] Resharper intellisense not working w/o SP1

I've been having problems with no Resharper intellisense appearing on four different builds of 2.5 on my work machine, the most recent of which being build 349. This is a Win2K box with VS2005 without Service Pack 1 installed.

On my home machine with SP1 installed, the Resharper intellisense is appearing correctly.

Any suggestions? As I said I have installed/uninstalled multiple Resharper builds, and toggled multiple times between the "Visual Studio Intellisense" and "Resharper Intellisense" options. VS Intellisense does work ok (in it's inferior to Resharper sort of way!).

Yet when I have it set to "Resharper" on this machine, if I type for instance:


And press the period key nothing happens... If I start typing a method name (e.g. "W") and do Ctrl+space it shows the Resharper intellisense, and other intellisense features like Ctrl-Shift-Space, ctrl-P etc are working.

But the initial "auto-completion" aspect of pressing a period and popping up the intellisense window stubbornly refuses to appear.

Any suggestions?

Comment actions Permalink

A further update on this. One of my colleagues installed and on his machine and the intellisesnse was ok.

However I jumped on it do something, pressed ctrl+P and up came the dialog asking whether to change the shortcut from File.Print etc. I chose to change and ticked the box saying "Dont ask me again" before clicking OK.

Immediately from that point onwards the intellisense then stopped working for him in the same way it did for me too (he isn't very happy about that!).

Does that help?

Comment actions Permalink

Have you tried changing the options in the intellisense R# | Options dialog?
I had something similar a while back....I seem to remember the VS options
in the Text Editor\C#\General section was set to allow VS to show parameter
info and list the members. Also there is a mirror of these settings the
Text Editor\All Languages section. Try changing these to give all the options
back to R# and see if that helps. You could also check the key mappings
in VS Options in Environment\Keyboard.



Comment actions Permalink


You are a star mate - spot on the money. For some reason all the options for "Auto-popup" in code completion were unchecked. Tick them and my IDE becomes much more pleasant to use.

What does intrigue me is as per my last post the fact that for my colleague the exact same thing happened to him while we were sitting there working as described - one minute the auto-popup was working, then after responding to the Resharper dialog by saying "Use Resharper defaults for all my keyboard commands" it instantly stopped working. I will check his machine tomorrow but undoubtedly it has suffered the same unticked checkbox fate as mine.

Perhaps there is something in that functionality which is unchecking them?

Thanks very much for the response - much happier now!

Comment actions Permalink

Glad it worked, Grant. I think it's caused by the hidden feature in VS -
'Resets Random Option'! My IDE (VS Tean Foundation SP1) does this regularly
- and not just with R# settings either. It seems that the 'break when CLR
exception is thrown' is one of its favourites....grrrrr!!!

Happy resharping!



Please sign in to leave a comment.