[1250] After Install VS 2008 Hangs While "Loading Assemblies"

For the last two daily builds, after doing an upgrade install of R#, when
opening our standard solution from the solution file (double click on
solution file from windows explorer), VS2008 will start up, the normal R#
dialog willl show (setup for the first time), the status bar will show
"Loading Assemblies" with a very small orange bar in it and VS will stop.
No CPU activity, and when looking at the Threads pane in the properties via
Process Explorer, everything is "n/a". I left it this way for 20 mins. If
I then kill the VS process, delete the ]]>.4.5.reshaper.user
file in the solution directory, and restart every thing is good.


4 comments

I have a similar issue with 1250, and just got 1251 and still have the
problem.

I have a file (just added to project) that does not have the correct
dependencies in the project. I will add them when I can... For now, the
VS.Net entirely locks up, putting one CPU to 100% and gradually eating up
more and more memory.

For me, the "Loading Assemblies" completes, then, while doing what must be
the background compile, it freezes, as just decribed.

I've restarted VS.NET a few times, then restarted the computer... always the
same problem.

I'll have to go back to 1248 until this is resolved.

I never get the chance to report this error to Resharper via the built in
error submission system, since it freezes up.

Glen



0

Hello Glen,

Thanks for the feedback.
What types of projects do you have in your solution? Is this freeze reproducible
if you'll try to add file to the simple ClassLib (for example) project? Are
there any additional plugins or source control system in your working environment
?

--
Kirill Falk
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I have a similar issue with 1250, and just got 1251 and still have the
problem.

I have a file (just added to project) that does not have the correct
dependencies in the project. I will add them when I can... For now,
the VS.Net entirely locks up, putting one CPU to 100% and gradually
eating up more and more memory.

For me, the "Loading Assemblies" completes, then, while doing what
must be the background compile, it freezes, as just decribed.

I've restarted VS.NET a few times, then restarted the computer...
always the same problem.

I'll have to go back to 1248 until this is resolved.

I never get the chance to report this error to Resharper via the built
in error submission system, since it freezes up.

Glen



0

I am having the same problem.  The solutions contain class libraries (C#), a web project, and unit test projects.  We are using TFS in Visual Studio 2008.  Also have MVC installed.  No other plugins.  Vista SP2 x86.

0

I tried a newer version, and have been running 1256 with no problems...

Glen



"Darin Heuermann" <no_reply@jetbrains.com> wrote in message
news:3801498.83681245072081272.JavaMail.clearspace@app8.labs.intellij.net...
>I am having the same problem. The solutions contain class libraries (C#), a
>web project, and unit test projects. We are using TFS in Visual Studio
>2008. Also have MVC installed. No other plugins. Vista SP2 x86.
>

---
Original message URL:
http://www.jetbrains.net/devnet/message/5240072#5240072



0

Please sign in to leave a comment.