Re# 5.0.1616.5 : disabling ReSharper without un-installing it ?

Win Vista SP2

Visual Studio 2010 RC1

WinForms C#

I am running into some strange crashes (Visual Studio suddenly shuts down completely with no error message) trying to use a demo WinForms app that shows off a 3rd. party control. Can inspect the code of the MainForm, run the demo, but trying to view the MainForm in Design-Mode crashes VS 2010 RC 1.

While I'd bet with a confidence level of 99.99999% that the crashes have nothing to do with ReSharper, what I would really like to know is if there is any way to completely take ReSharper "off-line" in Visual Studio 2010 RC 1 : without actually un-installing it.

Before I write to the 3rd. party control vendor, to describe the crashing, I feel kind of "duty bound" to at least try their code without ReSharper present, given its beta status, but it is time consuming to un-install Re#, the re-install it from "scratch."

My guess is that just unchecking the checkbox at : ReSharper/Options/Code Inspection/Settings/Enable Code Analysis

Does not really "clear the decks" enough for me to have eliminated ReSharper from consideration.

It really does seem curious that ReSharper does not show up in the Add-In or Extensions Manager, and cannot be disabled without un-install.

thanks, Bill

4 comments

I came across this option in Tools -> ReSharper -> Suspend ReSharper

Hope that helps.

0

Thanks, Graham !

That setting is under Visual Studio 2010 RC1 : Tools/Options/ReSharper : I was focusing my search on ReSharpers's own Options menu.

best, Bill

0

Sorry, yes I missed the 'Options' part!

0

Hello,

Thanks ! That setting is under Visual Studio 2010 RC1 :
Tools/Options/ReSharper : I was focusing my search on ReSharper' own
Options menu.


Even though we could plant the Suspend command in ReSharper options, it would
be very confusing by the moment you'd like to bring ReSharper back, for the
ReSharper options would be gone with the rest of the product )


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

Please sign in to leave a comment.