R# could not find .NET Framework

since the last two builds i have problems to open C# projects in Visual Studio 2008. If the target framework is set to ",NET Framework 3.5" i get an exception "Could not find ".NETFrameWork" version "3.5.0" and all keywords and references to framework libraries are marked red. If i switch the target framework to 3.0 or 2.0 everything is ok. I have reported several exceptions of this to YouTrack, for example RSPR-259763

Regards
Klaus

11 comments
Comment actions Permalink

Hello Klaus,

This problem should have been fixed yesterday. Does this still happen for
you with build 2143? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

since the last two builds i have problems to open C# projects in
Visual Studio 2008. If the target framework is set to ",NET Framework
3.5" i get an exception "Could not find ".NETFrameWork" version
"3.5.0" and all keywords and references to framework libraries are
marked red. If i switch the target framework to 3.0 or 2.0 everything
is ok. I have reported several exceptions of this to YouTrack, for
example http://youtrack.jetbrains.net/issue/RSRP-259763

Regards
Klaus
---
Original message URL:
http://devnet.jetbrains.net/message/5301555#5301555



0
Comment actions Permalink

yes it will. I'm always using the latest build :)

Maybe it's due to my configuration. First i'm using a localized verion of Visual Studio 2008. The customer i'm working for is very
restrictive with user rights so i don't have administrator privileges and mostly can't install software myself. To get an english
Visual Studio i just copied the localization files from another pc and set the language to english via vommand line option of
devenv.exe. On the other hand i'm not quite sure if the customer installed Visual Studio SP1 and .NET Framework 3.5 SP1 (i'm at home
at the moment so i can't verify).

Regards
Klaus

0
Comment actions Permalink

just installed build 2144 and the problem remains there.

Regards
Klaus

0
Comment actions Permalink

Hello Klaus,

Thank you for this information! We'll keep looking into this problem.

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

just installed build 2144 and the problem remains there.

Regards
Klaus
---
Original message URL:
http://devnet.jetbrains.net/message/5301635#5301635



0
Comment actions Permalink

thanks for the feedback.

Please take a look at my latest post about frequent exceptions on mouse clicks in build 2144. Maybe the problems are related.

Regards
Klaus

0
Comment actions Permalink

Hello Klaus,

Could you please gather the following information:
1. Directory structure for   "C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\"
and "C:\Windows\Microsoft.NET\Framework\". You can get the structure by running
"dir /A:D /S /B > C:\out.txt"
2. Contents of "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework"
registry key ("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework" if you
have a 32-bit OS). You can export the contents into a .reg file via regedit
-> export.

This would really help us to diagnose this problem. Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

thanks for the feedback.

Please take a look at my latest post about frequent exceptions on
mouse clicks in build 2144. Maybe the problems are related.

Regards
Klaus
---
Original message URL:
http://devnet.jetbrains.net/message/5301666#5301666



0
Comment actions Permalink

Hello Andrey,

unfortunately i already leave my working place and will not be back there until monday. But then i will send you the information as
soon as possible.

I just loaded the same solution into VS 2010 at home and have no problems with it at all (using EAP build 2144).

Regards
Klaus

0
Comment actions Permalink

Hello Andrey,

here is the requested information.

Regards
Klaus



Attachment(s):
RequestedInfo.7z.zip
0
Comment actions Permalink

I too have been experiencing the exact same issue that Klaus reported.  I'm using Visual Studio 2008 SP1 on a developer VM that also includes SQL Server Business Intelligence Development Studio (BIDS) for creating and testing SQL Server Integration Services (SSIS) packages.  The SQL Server 2008 SP1 instance is located on a separate machine, so when I say "installed BIDS", I mean the "client tools" portion.


At first I thought maybe the recent installation of BIDS had something to do with the sudden onset of the error I'm seeing in Visual Studio, but after reading Klaus'es original post, I'm convinced that ReSharper 6.0 EAP is seriously broken in all builds created on or after about 2011-04-27.

My copy of %programfiles(x86)%\Reference Assemblies\Microsoft\Framework\ looks like this:
C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\v3.0
C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\v3.5
C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\v3.0\en
C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\v3.0\RedistList
C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\v3.0\SubsetList
C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\v3.5\RedistList
C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\v3.5\SubsetList

I won't post the exported Registry information, but I have a feeling that nothing unusual will be found in it.

I look forward to seeing a new build that fixes this issue as soon as possible.

0
Comment actions Permalink

i just installed build 2145 and the problem seems to be fixed now.

Thanks
Klaus

0
Comment actions Permalink

I tried the latest build on a new VM without BIDS installed and the issue seems have been fixed.

0

Please sign in to leave a comment.