All recent 6.1 builds unusable with VS2008

Youtrack doesn't give much confidence that this bug  (and it's related duplicates) is being taken seriously.

I am today going back to 6.0 again, because 6.1 (other than the first EAP release, which has now timed-out) still cannot be used with a VS2008 solution here.  (Complicated mixed CE/Win32 solution, but has always worked fairly well with Resharper)

Just to make it clear, when this happens, almost none of Resharper works on that solution - no Ctrl-T, no global error detection, no Intellisense.

Whatever the problem is, it's happened during the EAP, not before it.

Personally, I've not really seen much change in 6.1, so I'm not really bothered about going back to 6.0, but you guys might have a concern about it being unusable, and hence getting no test feedback.   I haven't seen the same problems in 2010, but obviously we don't have WinCE projects in 2010, so I can't tell what triggers this failure.

Andrey Serebryansky

Hello Will
     I wasn't able to reproduce this problem on a small solution in VS2008. Could you please try creating a small sample, so that we could reproduce and investigate this problem on our side? Also, is this behavior solution-related (e.g. other solutions are fine in VS2008) or machine-related (e.g. ReSharper works fine with this solution on your colleague's machines)? Thank you!

Andrey Serebryansky

Senior Support Engineer

JetBrains, Inc

"Develop with pleasure!"



The only VS2008 solutions I still use are very complicated mixed CE/Native/.NET/.NETCF.   I'm not able to send this solution to you, I'm afraid.

If I miraculously find a spare hour or two I'll try and narrow this down.   There is a commentor on one of those linked bugs who appears to have seen the same thing - i.e. that the first 6.1 EAP worked, but later ones have failed.




Please sign in to leave a comment.