NAnt intellisense in plain text?!? Makes typing impossible...

R

  1. is giving intellisense inside attribute text values. This is totally inappropriate when we're just typing text:


For example, I tried to type the text:

"Probably a version"

but due to intellisense it came out as:

"Probably append version"

This is inside an tag, as in ]]>

The intellisense should not trigger inside attribute values.

9 comments
Comment actions Permalink

Hello Samuel,

We were unable to reproduce this problem. Do you get code completion in all
attributes?

Andrew

R

  1. is giving intellisense inside attribute text values. This is

totally inappropriate when we're just typing text:

For example, I tried to type the text:

"Probably a version"

but due to intellisense it came out as:

"Probably append version"

This is inside an <echo> tag, as in

<echo message="Probably a version" />

The intellisense should not trigger inside attribute values.



0
Comment actions Permalink

Yes, I get code hints in all attributes when I type a space. See attached screen shot.

Thanks,

Sam



Attachment(s):
NantIntellisense.PNG
0
Comment actions Permalink

Samuel,

Do You have the completion option 'auto-popup after a character is typed'
on?
If yes, switching it off will remove this annoying completion, but anyway,
this is a bug, that we will address ASAP.
--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

The option "auto-popup after a character is typed" is not checked.

I am able to work around the problem by using instead of ]]> since echo is really the only tag where I'm typing random text.

Would it be helpful if I sent you my xsd and build script? I don't want to post publicly but I'll be happy to e-mail to you directly.

Thanks,

Sam

0
Comment actions Permalink

Samuel,

Would it be helpful if I sent you my xsd and build script? I don't want
to post publicly but I'll be happy to e-mail to you directly.

Yes, it would be great.
--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Hello Samuel,

Which type of IntelliSense do you use? (go to ReSharper > Options < IntelliSense
tab and check the "Use IntelliSense features of" option). If you're using
Visual Studio's IntelliSense, please try to switch to ReSharper's one.

Thanks,
Andrew

The option "auto-popup after a character is typed" is not checked.

I am able to work around the problem by using <echo></echo> instead of
<echo message="" /> since echo is really the only tag where I'm typing
random text.

Would it be helpful if I sent you my xsd and build script? I don't
want to post publicly but I'll be happy to e-mail to you directly.

Thanks,

Sam



0
Comment actions Permalink

Hello Samuel,

Please also do the following: go to Tools > Options > Text Editor > XML >
General tab and uncheck the "Auto-list members" and "Parameter information"
options.

Thanks,
Andrew

Yes, I get code hints in all attributes when I type a space. See
attached screen shot.

Thanks,

Sam



0
Comment actions Permalink

ReSharper intellisense is already selected

0
Comment actions Permalink

Hello Samuel,

According to the screenshot you've sent to us, the code completion popup
in attribute's values is provided by Visual Studio. Try to switch off code
completion in Xml: go to Tools > Options > Text Editor > Xml > General tab
and uncheck the "Auto-list members" option. To get ReSharper's code completion
popup you should press Ctrl+Space.

Thanks,
Andrew

ReSharper intellisense is already selected



0

Please sign in to leave a comment.