Failed to initialize Resharper 2.5 (build 376)

When I start visual studio, Resharper throws some errors like:

"Failed to initialize Menu Action ShowTooltips" .... and some more ...

finally after 4-5 errors the Resharper Menu is visible but whithout some menu options.
When I try to click some more menu options the error comes back again and ask me if I want to remove them....

can anyone help me in this issue?

thanks,
Jose Cruz

9 comments
Comment actions Permalink

Hello Jose,

the recommended way to combat this problem is as follows:

1) Disable Resharper in Add-In Manager
2) Choose Tools|Import and Export Settings|Reset All Settings
3) Close VS
4) Launch VS and enable ReSharper in Add-In Manager, if necessary.

Please notify us if this doesn't help.

Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


When I start visual studio, Resharper throws some errors like:

"Failed to initialize Menu Action ShowTooltips" .... and some more ...

finally after 4-5 errors the Resharper Menu is visible but whithout
some menu options.

When I try to click some more menu options the error comes back again
and ask me if I want to remove them....

can anyone help me in this issue?

thanks,
Jose Cruz



0
Comment actions Permalink

It keeps with this message:

"Failed To create command ShowTips, details: A command with that name already exists"

0
Comment actions Permalink

One think:
- It was a fresh install of visual studio 2005 + Resharper

0
Comment actions Permalink

Hello Jose,

was ReSharper ever installed on this machine before? Could you please check
what commands containing
'ShowTips' exist in the Tools|Options|Environment|Keyboard dialog?


Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


One think:
- It was a fresh install of visual studio 2005 + Resharper



0
Comment actions Permalink

ShowTips doesnt exist in keyboard-commands.

One thing that I hope it helps is the fact that when I do a remove reshaper and reset settings (import/export) the commands "Reshaper.addinxxxx" stills exists event without resharper...

0
Comment actions Permalink

Hello Jose,

could you please try to remove manually the following VS config file:

"C:\Documents and Settings\<user-name>\Application Data\Microsoft\VisualStudio\8.0\1033\CmdUI.PRF"


and check if it helps? This file doesn't contain any important data, this
is merely a cache of VS commands.


Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


ShowTips doesnt exist in keyboard-commands.

One thing that I hope it helps is the fact that when I do a remove
reshaper and reset settings (import/export) the commands
"Reshaper.addinxxxx" stills exists event without resharper...



0
Comment actions Permalink

After remove the file, it initializes well... but if i click Resharper Menu... then some options are disabled (licence, options, the bottom ones).
Then i restart visual studio and... it I think I get messages for all visual studio commands. I just cant initiate visual studio, this time.

0
Comment actions Permalink

Hello Jose,

do you mean you get all the messages 'Failed to create command...' again?
Thanks.


Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


After remove the file, it initializes well... but if i click Resharper
Menu... then some options are disabled (licence, options, the bottom
ones).

Then i restart visual studio and... it I think I get messages for all
visual studio commands. I just cant initiate visual studio, this time.



0
Comment actions Permalink

Yes!
I installed visual studio and resharper again. I removed all visual studio references in documents folders for all users... I can initiate resharper now, its working.. .but I had a message about language packs. Now I have only this message when I Click in Tools|options|(option without text!).. I don't know if is this is resharper issue.. but for now its working...

The message below:


-


Microsoft Visual Studio
-


Package Load Failure

Package 'DataWarehouse VSIntegration layer' has failed to load properly ( GUID = {4A0C6509-BF90-43DA-ABEE-0ABA3A8527F1} ). Please contact package vendor for assistance. Application restart is recommended, due to possible environment corruption. Would you like to disable loading this package in the future? You may use 'devenv /resetskippkgs' to re-enable package loading.
-


Yes No
-


0

Please sign in to leave a comment.