Annoying Resharper Reformatting issue.

Hi my compnay has bought resharper and I'm testing it for our group.
So far it's better than Visual Assist X, which is what i've been using before.

Unfortunately today, I've encountered some painful behaviour that i cannot
remedy.

I'm trying to type a simple if /else construct.

I want it to come out looking like this


if(x==1)
{
//do some stuff
}
else
{
// do some other stuff.
}

unfortunately, it keeps indenting my else, and my else braces

if()
{
{
else
{
}

The net effect is that I have to hit 3 times while typing this construct to get the formatting I want. I have gone to Resharper->options->c#->]]>LineBreaks and Wrapping and cannot find a setting which controls this behavior.

What setting do I need to change to cease the indenting of my if thens?

2 comments
Comment actions Permalink

I can't say I've ever seen Resharper do that. What version and build are
you running?

"caladin" <no_reply@jetbrains.com> wrote in message
news:23503209.1184954905567.JavaMail.itn@is.intellij.net...

Hi my compnay has bought resharper and I'm testing it for our group.
So far it's better than Visual Assist X, which is what i've been using
before.

>

Unfortunately today, I've encountered some painful behaviour that i cannot
remedy.

>

I'm trying to type a simple if /else construct.

>

I want it to come out looking like this

>
>

if(x==1)
{
//do some stuff
}
else
{
// do some other stuff.
}

>

unfortunately, it keeps indenting my else, and my else braces

>

if()
{
{
else
{
}

>

The net effect is that I have to hit <BackSpace> 3 times while typing this
construct to get the formatting I want.

>

I have gone to Resharper->options->c#->LineBreaks and Wrapping and cannot
find a setting which controls this behavior.

>

What setting do I need to change to cease the indenting of my if thens?


0
Comment actions Permalink

3.0.456.31

How can i reset the options to defaults, incase that's the issue?

0

Please sign in to leave a comment.