RS formatting items not working in 4.0?

I just upgraded to 4.0, and now the syntax highlighting seems not to work anymore. For example, the current line is no longer highlighted, although I can see in Tools -> Options -> Fonts and Colors that it is set to a nice yellow color. Is this a known bug in 4.0, and if so, is there a known solution? The other RS syntax highlighting items seem not to work too, in fact I'm back to boring VS highlighting...

I can see all the RS items in Fonts and Colors dialog but they don't seem to have any effect.

3 comments
Comment actions Permalink

Have you confirmed in the R# settings that it is to color the identifiers? Some have noticed that this setting becomes unchecked after upgrading.

0
Comment actions Permalink

Thanks Jeremy, that's exactly what was wrong.

For people with the same problem, I can add that the option is found here: ReSharper -> Options -> Code Inspection -> Settings -> Color identifiers. Does anyone know why this option is reset when updating?

Also, to (re)enable highlighting of current line go here: ReSharper -> Options -> Editor -> Highlight current line.

Martin

0
Comment actions Permalink

Hello,

For people with the same problem, I can add that the option is found
here: ReSharper -> Options -> Code Inspection -> Settings -> Color
identifiers. Does anyone know why this option is reset when updating?


There were changes to the code analysis settings schema in R#4. Possibly
some migration policy is missing. We'll check, thanks for reporting.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

Please sign in to leave a comment.