Live Templates Consecutive Variables Problem

I've been creating some C# live templates in Resharper 4, but I've been encountering an issue when I have multiple consecutive variables. When I use my live template, not all the variables are available for data entry. For example, I use the following live template:

$TEST$$TEST1$$TEST2$

When I use the live template, only the TEST2 is displayed in Visual Studio 2008. Is there something I'm doing wrong?

Thanks,

Dave

Edited by: irish3474 on Oct 9, 2008 6:11 PM

4 comments
Comment actions Permalink

Is $TEST$$TEST1$$TEST2$ the entire contents of the template? I just created a template with this content, and all three showed up just fine. On the right-hand pane of the template editor all three have the "Editable Occurrence" box checked. Is that the case for your template as well?

0
Comment actions Permalink

Yes, that's what I did also. I've attached a screen shot of the live template which may show what I'm doing wrong ( I tried exporting the live template, but it didn't look correct).

Thanks,

Dave



Attachment(s):
livetemplate.png
0
Comment actions Permalink

Very weird. That's exactly what mine looks like. When I expand the template, I see TESTTEST1TEST2 and I'm able to edit all three portions of that text individually. I have no idea why your template behaves differently. Sorry.

0
Comment actions Permalink

I upgraded to Resharper 4.1 and the problem was fixed. I'm not sure whether I had a local installation problem with 4.0 or it was fixed in 4.1. Regardless of solution, it works now.

Dave

0

Please sign in to leave a comment.