EAP 4.5 warning for undocumented code.

Hi,

Just installed 4.5 # 1144 and notice the new warnings for undocumented code.
I want to disable this warning but the lightbulp only gives an option to
remove the warning with a #pragma.

How do I disable the warning global for my solution ?


6 comments

Does C# compiler issue this warning in your solution?

--
Eugene Pasynkov
ReSharper Technical Lead
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"


"John" <open@yahoo.com> wrote in message
news:gjah2a$6f1$1@is.intellij.net...

Hi,

>

Just installed 4.5 # 1144 and notice the new warnings for undocumented
code. I want to disable this warning but the lightbulp only gives an
option to remove the warning with a #pragma.

>

How do I disable the warning global for my solution ?

>



0

Hi,

Yes it does. I have now disabled the 'XML documentation file' under the
projects build settings to get rid of these warnings.

Is it a VS2008 setting that gives these warnings and not Resharper ?


"Eugene Pasynkov (JetBrains)" <Eugene.Pasynkov@jetbrains.com> wrote in
message news:gjb982$2la$1@is.intellij.net...

Does C# compiler issue this warning in your solution?

>

--
Eugene Pasynkov
ReSharper Technical Lead
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"

>
>

"John" <open@yahoo.com> wrote in message
news:gjah2a$6f1$1@is.intellij.net...

>> Hi,
>>
>> Just installed 4.5 # 1144 and notice the new warnings for undocumented
>> code. I want to disable this warning but the lightbulp only gives an
>> option to remove the warning with a #pragma.
>>
>> How do I disable the warning global for my solution ?
>>
>>
>


0

Hi,

I have now changed my build settings to have a 'Warning level: of 4 and
'Suppress warnings:' 1591 and I have a checkmark on 'XML documentation
file'. This removes the warnings from VS2008 warning list on a build, but
Resharper still reports the warnings in the text editor.


"Eugene Pasynkov (JetBrains)" <Eugene.Pasynkov@jetbrains.com> wrote in
message news:gjb982$2la$1@is.intellij.net...

Does C# compiler issue this warning in your solution?

>

--
Eugene Pasynkov
ReSharper Technical Lead
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"

>
>

"John" <open@yahoo.com> wrote in message
news:gjah2a$6f1$1@is.intellij.net...

>> Hi,
>>
>> Just installed 4.5 # 1144 and notice the new warnings for undocumented
>> code. I want to disable this warning but the lightbulp only gives an
>> option to remove the warning with a #pragma.
>>
>> How do I disable the warning global for my solution ?
>>
>>
>


0

ReSharper synchronizes with VS. I.e. this is ReSharper's warning, and it is
shown/hidden by corresponding project build setting

--
Eugene Pasynkov
ReSharper Technical Lead
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"


"John" <open@yahoo.com> wrote in message
news:gjckid$luq$1@is.intellij.net...

Hi,

>

Yes it does. I have now disabled the 'XML documentation file' under the
projects build settings to get rid of these warnings.

>

Is it a VS2008 setting that gives these warnings and not Resharper ?

>
>

"Eugene Pasynkov (JetBrains)" <Eugene.Pasynkov@jetbrains.com> wrote in
message news:gjb982$2la$1@is.intellij.net...

>> Does C# compiler issue this warning in your solution?
>>
>> --
>> Eugene Pasynkov
>> ReSharper Technical Lead
>> JetBrains, Inc.
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>
>>
>> "John" <open@yahoo.com> wrote in message
>> news:gjah2a$6f1$1@is.intellij.net...
>>> Hi,
>>>
>>> Just installed 4.5 # 1144 and notice the new warnings for undocumented
>>> code. I want to disable this warning but the lightbulp only gives an
>>> option to remove the warning with a #pragma.
>>>
>>> How do I disable the warning global for my solution ?
>>>
>>>
>>
>>



0

Sounds like a bug in ReSharper
Please could you post 2 screenshots - 1) with build settings where you've
turned this warning off, and 2) piece of code where ReSharper issues this
warning

--
Eugene Pasynkov
ReSharper Technical Lead
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"


"John" <open@yahoo.com> wrote in message
news:gjcmfv$18m$1@is.intellij.net...

Hi,

>

I have now changed my build settings to have a 'Warning level: of 4 and
'Suppress warnings:' 1591 and I have a checkmark on 'XML documentation
file'. This removes the warnings from VS2008 warning list on a build, but
Resharper still reports the warnings in the text editor.

>
>

"Eugene Pasynkov (JetBrains)" <Eugene.Pasynkov@jetbrains.com> wrote in
message news:gjb982$2la$1@is.intellij.net...

>> Does C# compiler issue this warning in your solution?
>>
>> --
>> Eugene Pasynkov
>> ReSharper Technical Lead
>> JetBrains, Inc.
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>
>>
>> "John" <open@yahoo.com> wrote in message
>> news:gjah2a$6f1$1@is.intellij.net...
>>> Hi,
>>>
>>> Just installed 4.5 # 1144 and notice the new warnings for undocumented
>>> code. I want to disable this warning but the lightbulp only gives an
>>> option to remove the warning with a #pragma.
>>>
>>> How do I disable the warning global for my solution ?
>>>
>>>
>>
>>



0

Hi,

I have uninstalled 4.5 and will wait to the next stable build.
I am back to version 4.1.943.5 where there is no problem.

This is my build settings of my dll project.



"Eugene Pasynkov (JetBrains)" <Eugene.Pasynkov@jetbrains.com> wrote in
message news:gjgjrv$llj$1@is.intellij.net...

Sounds like a bug in ReSharper
Please could you post 2 screenshots - 1) with build settings where you've
turned this warning off, and 2) piece of code where ReSharper issues this
warning

>

--
Eugene Pasynkov
ReSharper Technical Lead
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"

>
>

"John" <open@yahoo.com> wrote in message
news:gjcmfv$18m$1@is.intellij.net...

>> Hi,
>>
>> I have now changed my build settings to have a 'Warning level: of 4 and
>> 'Suppress warnings:' 1591 and I have a checkmark on 'XML documentation
>> file'. This removes the warnings from VS2008 warning list on a build, but
>> Resharper still reports the warnings in the text editor.
>>
>>
>> "Eugene Pasynkov (JetBrains)" <Eugene.Pasynkov@jetbrains.com> wrote in
>> message news:gjb982$2la$1@is.intellij.net...
>>> Does C# compiler issue this warning in your solution?
>>>
>>> --
>>> Eugene Pasynkov
>>> ReSharper Technical Lead
>>> JetBrains, Inc.
>>> http://www.jetbrains.com
>>> "Develop with pleasure!"
>>>
>>>
>>> "John" <open@yahoo.com> wrote in message
>>> news:gjah2a$6f1$1@is.intellij.net...
>>>> Hi,
>>>>
>>>> Just installed 4.5 # 1144 and notice the new warnings for undocumented
>>>> code. I want to disable this warning but the lightbulp only gives an
>>>> option to remove the warning with a #pragma.
>>>>
>>>> How do I disable the warning global for my solution ?
>>>>
>>>>
>>>
>>>
>>
>

0

Please sign in to leave a comment.