"Analysis is switched off"

For some reason, a file in my one of my projects is not providing highlighting or warning. In the status column on the right of the editing Pane the top box is grey and provides  hover help of "Analysis is switched off". Other files seem to display this and highlight just fine.

I tried turing off Solution wide analysis and flushing cache but nothing seems to get this file back under analysis. I noticed some OLD reports of similar problems but haven't been able to resolve them under 4.5.2.

Any suggestions?

Thanks

18 comments
Avatar
Andrey Serebryansky
Comment actions Permalink

Hello Otis
     Please make sure that your file is not listed under ReSharper > Options > Code Inspection > Settings > Advanced.... Let me know if this helps. Thank you!

Andrey Serebryansky

Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0
Comment actions Permalink

That was it!

Though I have NO idea how it got in there. I hadn't managed to find that dialog before while trying to solve the probelm.

Thanks for the quick responce.

0
Comment actions Permalink

Hello,

Though I have NO idea how it got in there. I hadn't managed to find
that dialog before while trying to solve the probelm.


Well, there's some nontrivial keyboard shortcut for that, for diagnostic
purposes. Could have hit it accidentally.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

2018 - August - i have this issue where there's a pause icon on resharper in the upper right, and i am unable to type in any code in VS unless i go and suspend resharper. Is there any suggestion, there are no file set in ReSharper > Options > Code Inspection > Settings. (there's no longer an Advanced under that menu). Any input is GREATLY appreciated! Thanks

0
Comment actions Permalink

Hello Amit!

 

Could you please specify if the problem is reproduced for all files in the solution or just specific ones?

Files skipped from analysis are specified in ReSharper | Options | Code Inspection | Settings | Elements to skip.

Thank you.

0
Comment actions Permalink

I had the same problem with one of our largest c++ files.

<s:Int64 x:Key="/Default/PerformanceThreshold/AnalysisFileSizeThreshold/=CPP/@EntryIndexedValue">1800000</s:Int64>

After adding the line into this file

'%AppData%\JetBrains\Shared\vAny\GlobalSettingsStorage.DotSettings'

 the analyzer could go through it.

I'm working with Visual Studio 2022 and the latest Resharper 2022.1 EAP 9.

I would suppose to dump at least a warning somewhere that the file is too large...

 

0
Comment actions Permalink

Alexander Golde, thank you for your feedback. An explanation of why analysis is disabled for a file can be seen in the message that appears when you move the mouse over the "pause" icon. Please let me know if you have any questions. Thank you!

0
Comment actions Permalink

Hello Maria,

Where can I find the 'Pause' icon?
On which windows should I search?

 

0
Comment actions Permalink

Alexander Golde, sorry for my bad explanation. The "pause" icon should be at the top of the vertical scrollbar. Here is an example of what it looks like:

0
Comment actions Permalink

Got it, thank you. I had to enable the Marker first :)

Resharper/Options/Environment/Editor/Appearance

0
Comment actions Permalink

BTW, there's no need to modify the file GlobalSettingsStorage.DotSettings anymore.

0
Comment actions Permalink

Alexander Golde, sometimes modifying GlobalSettingsStorage.DotSettings file is convenient if there are a lot of large files in the solution. In this case, one line in dotSettings file enables analysis in all large files, and there is no need to enable analysis in each individual file.

0
Comment actions Permalink

I see.

Is there a rule where to add this line and is it completely correct?

<s:Int64 x:Key="/Default/PerformanceThreshold/AnalysisFileSizeThreshold/=CPP/@EntryIndexedValue">1800000</s:Int64>

I'm asking because the 'Options' dialog lost quite a few tree nodes :(

After removing the line the nodes came back.

0
Comment actions Permalink

The line looks correct.

The main rule is to insert this line anywhere before the closing tag - "</wpf:ResourceDictionary>". 

I'm asking because the 'Options' dialog lost quite a few tree nodes :(

Could you please attach a screenshot that demonstrates the problem with tree nodes? Thank you!

0
Comment actions Permalink

Hmm, I cannot reproduce that anymore, very strange.

This is the actual view.

I would say all of the language specific Code Editing nodes were invisible.

The Tools section was filled with only 3-4 nodes.

Definetely stripped down tree. It was the cause for my reply at 10:48.

Sorry.

0
Comment actions Permalink

If the problem happens again, please let us know. Have a nice day! :)

0
Comment actions Permalink

Hello,

it happened again:

Is there a log file which could help?

0
Comment actions Permalink

After a restart of VS all options are back again..

0

Please sign in to leave a comment.