"The test did not run or did not complete normally due to an error. Refer to the Gallio Test Report and ReSharper Log for more details."

I'm running v4.5.1288.2 with Gallio 3.1 Update 1 build 367, and i just started getting the following error when I try to run any MbUnit tests:

"The test did not run or did not complete normally due to an error.  Refer to the Gallio Test Report and ReSharper Log for more details."

I don't know what to do.  Please help.

7 comments

Hi,

I seem to be facing the same issue? Any update/resolution on this?

Thanks,
Azhar.

-Visual Sudio 2008 ver. 9.0.30729.1
.NET 3.5 sp1
R#: 4.5.1288.2
Gallio 3.1

0

Hello Azhar and Paul
     Please try debugging your tests with option 'Thrown' for Common Language Runtime exceptions turned on (under Debug > Exceptions). Do you see any exception messages? Thank you!

Andrey Serebryansky

Support Engineer

JetBrains, Inc

http://www.jetbrains.com

"Develop with pleasure!"

0

Thanks Andrey for your suggestion.
I've enabled debug exceptions and now all exceptions are to be thrown i.e. C++,CLR, MDA,Win32. The only exception that I actually get when I try to debug is 'LoadFromContext' exception. Other, than that I still get the failure error via Gallio as reported earlier and all tests fail to run/debug.
I've also installed the following plug-in:

http://mbunit-resharper.googlecode.com/files/ReSharper-MbUnit-Beta10.zip

But, still no luck. Even though I have Gallio c3.1 installed on my machine, my test project is referencing MbUnitv2 (MbUnit.Framework dlls).

When, I switch my test project to use NUnit with resharper it works like a charm. Howver, every one else on my team is using MbUnit and it seems to work on their machines.

-Azhar.

0

My test project was referencing Mbunitv2 dlls.  When I upgrade my project to refernce the Gallio and MbUnit 3.1 dlls. Then I am able to debug/run my tests without any hitch. So it seems that in my test project the reference to older Mbunitv2 (MbUnit.Framework and MbUnitFramework.2.0 dlls) is causing some kind of incompatibality.

I've rebuild my project with Gallio and MbUnit 3.1 dll references and is running with re-sharper. Now I have to convince my team mates to upgrade to Gallio 3.1


-Azhar.

0

It should have worked fine with MbUnit v2.4.2 but I haven't checked in a while.  In any case, I'm glad you found a workaround.

0

We're running into it too on project of NUnit 2.5 integration tests, executed from R# (and TeamCity). Individually the test execute OK, but if I try to execute all the ones in the assembly, half or so of the tests execute fine (but slowly!), and about half of them seem to fail very quickly with "The test did not run or did not complete normally due to an error. Refer to the Gallio Test Report and ReSharper Log for more details.

I tried to have a look at the Gallio Test Report (by clicking the View Full Test Report icon) but VS goes mad on memory and CPU consumption and needs to be put down. Where do I find the R# log?

Version info:

Microsoft Visual Studio 2008 Version 9.0.30729.1 SP
Microsoft .NET Framework Version 3.5 SP1

Gallio   Version 3.1 build 397
Gallio integration for Visual Studio

ReSharper 4.5   C# Edition build 4.5.1274.1 on 2009-07-21T20:01:06
ReSharper add-in for Microsoft Visual Studio. For more information about ReSharper, see the ReSharper website at http://www.jetbrains.com/resharper. Copyright © 2003–2010 JetBrains, Inc

NUnit.Framework.dll 2.5.2.9222

0

I experiencing this error today after adding an improperly formatted app.config to the test project. When I removed the app.config file,  the tests ran as expected, which is when I noticed the error in the config file. When I corrected the file, the tests also ran as expected.

-- Chuck

0

Please sign in to leave a comment.