Cannot resolve symbol 'Response'

I have a .aspx file where I'm trying to write to the response.  The pages function correctly, but R# gives me the error that it cannot resolve the symbol 'Response'.

The following code reproduces the issue (New Web Application, edit the .aspx file to contain).  I've tried it both with and without the runat in the head tag (either way the web app functions properly, it's only Resharper that complains).


<head runat="server">
    <% Response.Write("Writing my response"); %>

The code I'm actually using is getting the info from a static function, but the above causes the problem, too:

<head runat="server">
    <% Response.Write(ExtendedPrompt.UtilityFunctions.getIncludes()); %>

Any ideas on how to make this go away?  Thanks!

1 comment
Comment actions Permalink

I am getting the same error. Is there any possible solution for this? Also i am getting another weird error. I have a code like:

<meta http-equiv="Refresh" content="0;url=<%Response.Write(redirectPage);%>" />

where redirectPage is a protected string in my cs file. Resharper returns me two errors. Cannot resolve symbol 'Response' and Cannot resolve symbol 'redirectPage'


Please sign in to leave a comment.