Cannot resolve symbol Linq

Dear All

Using R# 5.0.1533 for soem time now with Visual Studio 2010 (on win 7 professional) and suddenly today I find that all references to Linq are colored red and when I hover over it , it says cannot resolve symbol xxxx.

Suspending R# , all is well, resuming R# back to the red color and cannot resolve symbols.

var query = (from inv in invaders
                             group inv by inv.Location.X
                             into invgroup
                             select invgroup.OrderBy(inv => inv.Location.Y)).ToList();



Thanks.
Kev

6 comments

I am also experiencing this issue. See the following screenshot:

http://content.screencast.com/users/NathanRidley/folders/Jing/media/c300d460-910f-4502-9e4f-ec2c8a9c46c5/2010-05-20_1419.png

0

Looks Like no help from Resharper on this one.
I can't find anywhere ele to post this issue either.

Best rgds
kev

0

did you try to clear R#'s cache? This may help. Also try to install the release build 1539.

Regards
Klaus

0

Few questions:

1) Is this problem stably repeatable? If yes, is it possible to create small solution which demonstrates this problem?
2) Could you please try the latest 5.1 EAP build?

0

Thanks for the response.
As suddenly as it appeared, it dissappeared.
However I had made one change to my project and switched the default .net frameowrk target.
It was : .NET framework 4.0 Client Profile
to: .Net framework 4.0

This caused everything to start behaving normally !!!
Still not sure what caused it, in case it pops up again, will post with more details and also send out a sample project.

Thanks to Eugene and Klaus for their prompt responses.

P.S: how does one clear the R# Cache ?

0

ReSharper per-solution caches are located in the same folder where your .sln file is.
The folder with caches is named ***.ReSharper, where *** is you solution file name

0

Please sign in to leave a comment.