Turn Off Code Analysis on all ASPX Pages

I need to turn off code analysis on all ASPX pages because ReSharper 5.0 makes it impossible to code. It slows down VS 2008 to a stand still. How do I do that?

The command "Ctrl+Shift+Alt+8" does not work.

It is interesting to know that it wans't this slow when I was using the Trial License. I soon as I bought a full license, everything just slowed down and it is very anoying.

1 comment
Comment actions Permalink

1) Have you tried turning off Solution Wide Analysis?
2) Have you tried turning off Color identifiers? ReSharper\Options\Settings\Color identifiers
3) You can disable code analysis entirely: ReSharper\Options\Settings\Enable code analysis

4) Try the 5.1 EAP, it specifically addresses performance issues with ASPX: http://confluence.jetbrains.net/display/ReSharper/ReSharper+5.1+Nightly+Builds
5) If you still have problems it would be wonderful if you would grab dotTrace: http://www.jetbrains.com/profiler/ and take a snapshot.

Finally you can suspend all of ReSharper: Tools\Options\ReSharper  Note that this is Visual Studio's Options Dialog. ReSharper has a top level entry there.

0

Please sign in to leave a comment.