Why is Resharper 5.1 missing from the Add-In Manager dialog?

When I ran R# 4.5.x, there was a Resharper entry in the Add-In Manager (Tools/Add-In Manager).  Now that I've installed 5.1, the entry is no longer and I can't disable Resharper on as-needed basis.

How can I get the Resharper entry back into the Add-In Manager?
This is with Visual Studio 2008.

7 comments

You can disable/suspend Resharper under Tools > Options > ReSharper > General.
There is also a shortcut you could use. Search for suspend in Tools -> Environment -> Keyboard.

0

R# should still be in the list like all other extensions.

0

Hello Mike,

ReSharper 5 uses a slightly different integration method (compared to previous
versions of ReSharper) and it's not an add-in anymore. The Add-In Manager
window lists add-ins only, so ReSharper doesn't make it into that list. Thank
you!

Andrey Serebryansky
Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

R

  1. should still be in the list like all other extensions.


---
Original message URL:
http://devnet.jetbrains.net/message/5268995#5268995



0

carifio wrote:

R# should still be in the list like all other extensions.


Serge Baltic gave this answer some time ago

Yes. ReSharper improved its Visual Studio integration, and is not an Add-In
anymore.


source http://devnet.jetbrains.net/message/5253930

0

From the link:

Can it be restored?


No, but we thought it could be useful to suspend ReSharper temporarily, and
reimplemented this feature in UI (Tools | Options | ReSharper), keyboard-bindable
VS commands (ReSharper_ToggleSuspended plus a few more), and VS command-line
keys (ReSharper.Suspend, ReSharper.Resume).


That's good that I can bind it to a keyboard shortcut.  But why can't I bind it to a button on a toolbar?  When I right click on a toolbar and go into Customize, then pick the Resharper category, the ReSharper_ToggleSuspended command is nowhere to be found.

Am I missing something?

0

It is indeed missing from the commands list.

Until its fixed you can use a macro with this code as workaround

DTE.ExecuteCommand("Resharper_ToggleSuspended")

0

Please sign in to leave a comment.