How to turn off the exception toaster?

Hi,

Is there any way to turn off the exception toaster that pops up when an exception happens in Resharper?

I have submitted exception reports several times and I see its usefulness from both yours and ours (users) perspective but it is very distracting and annoying.

Jose

3 comments
Comment actions Permalink

Hello,

Is there any way to turn off the exception toaster that pops up when
an exception happens in Resharper?


What is your ReSharper version? In v5 and higher, you cannot turn it off
in prerelease builds, but it's off by default in release builds.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

Hi,

I have version 5.1 but I just installed the latest nightly which, by the way, is massive improvement in one project that has a 20k cs file.

I understand why I cannot turn it off in pre-release builds but I find it very intrusive maybe because it looks like an email arriving (which I turn off when coding). And sometimes it keeps popping up with repeats even if I tell it to ignore the exception. Anyway, I got the point, I just wish it wasn't so distracting.

Jose

0
Comment actions Permalink

Hello Jose,

ReSharper should not notify about an exception that has already been ignored.
Could you please attach a stack trace (technical details) of a "muted" exception
and an exception that occurred afterwards and that should have been "muted"
as well? Thank you!

Andrey Serebryansky
Senior Support Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hi,

I have version 5.1 but I just installed the latest nightly which, by
the way, is massive improvement in one project that has a 20k cs file.

I understand why I cannot turn it off in pre-release builds but I find
it very intrusive maybe because it looks like an email arriving (which
I turn off when coding). And sometimes it keeps popping up with
repeats even if I tell it to ignore the exception. Anyway, I got the
point, I just wish it wasn't so distracting.

Jose

---
Original message URL:
http://devnet.jetbrains.net/message/5274580#5274580



0

Please sign in to leave a comment.