How to disable javascript integration in ReSharper?

I find it completely impossible to edit javascript files in Visual Studio with ReSharper enabled.  Each and every character takes several seconds before the editor becomes responsive again.  The moment I disable ReSharper the problem goes away.  I have absolutely no interest whatsoever in whatever it is ReSharper is doing with javascript files, but I honestly don't need the help.  How can I disable the javascript portion of ReSharper?   It's an utter wreck when used with our solutions.  If it would help, I would be happy to provide profile results if someone tells me how.  

2 comments

Hi.
There is no way to disable js support. Most likely it is automatic code completion that causes this 'slow down'. We've fixed several performance problems there recently. Could please try switching it off R# intellisense?
Btw, do you use the latest nightly build?

0

Thanks for replying.  I apologize for not trying out the latest version before posting, but that did the trick for me.  Nice job with the latest versions, I don't notice a delay at all anymore in the javascript files.

0

Please sign in to leave a comment.