Dotnet projects.

Chaps,

I don't know what's going on but if you look at my screenshot you'll see that my solution explorer lists resharper's file as well as the ones I expect. In another solution, I have some resharper files but those don't show in the solution explorer. I don't know if it's something in the solution file that's doing it or whether it's controlled by some configuration setting that shows all the files. It might not even be a Resharper problem. Anyway, does anyone have an idea what I can do to "remove" the files from the solution that I don't want included? I can't find any obvious "remove from project" setting that will do it. There's a "delete from project" but that's permanent. I'm happy to keep the files but I'd like to "hide" them to reduce the clutter.

I've searched all the obvious settings but I can't see anything that will control it.

Thanks.



Attachment(s):
Screenshot.png
3 comments

It looks like you have 'Show All Files' turned on for the selected project (it can be turned on/off on a project basis.)  See the attached screen shot.  If you turn that off, the Solution Explorer will only show files that are actually part of the project.

David



Attachment(s):
ShowAllFiles.jpg
0

David,

I lower my head in total shame and could slap myself for being so stupid to ask such a question. In my defence I can only say that I'm using RS5 on one machine and RS6 on the other. I fooled myself into thinking that RS6 might need a tweak as that's all I "changed". Clearly I had activated the "show all files" without knowing it.:_|

Thanks for putting a fool back on the road to enlightenment.

0

Not a problem Oddstix.  We all sometimes get so focused it's hard to see the forest for the trees!  :D

Glad I could help!

0

Please sign in to leave a comment.