C# "Use explicit private modifier" not working

Hi. In C# I prefer to use explicit modifiers for private variables and I enjoy ReSharper's ability to automatically insert these; for example, if I type:

int _myInt;

then when I hit the semi-colon key, ReSharper will automatically add the private modifier, as in:

private int _myInt;


Recently this stopped working on my home computer, but it still functions correctly at my work computer. Both are running the same version (5) on VS2010. I have the option "Use explicit private modifier" checked in the C# > Formatting > Other options. I've tried unchecking it, clicking OK, re-opening options and checking it again, but to no avail.

Can anyone tell me why this is no longer functioning for me?


Thanks in advance.

2 comments
Comment actions Permalink

Hello,

Can anyone tell me why this is no longer functioning for me?


Not sure, but is the "reformat on semicolon" option on?


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

Yes it is, as is 'on closing brace'. 'Arrange modifiers in existing code' is also checked.

Actually, this has stopped working on my work computer too. Coding is a small part of my job so I couldn't tell you the last time it did work, but it couldn't have been more than 2-3 weeks. I can't think of any changes I made to options in that time.

Edit: This feature still works for my colleague, but he is running R# build 5.1.1753.4

I am running: Build 5.1.3000.12 on 2011-01-28T05:05:56

Licensed to: ####
Plugins: none.
Visual Studio 10.0.40219.1.


Is it possible that something between these two versions broke this feature?

0

Please sign in to leave a comment.