R#6 : How to disable auto-complete in *.aspx / *.ascx?

Or at least fix it so that it doesn't:

  1. change the case of every tag and attribute I type; and
  2. automatically insert double-quotes when I type the equals sign after an attribute.
    (NB: If the attribute value uses a Bind or Eval statement, double-quotes won't work!)


This is extremely annoying. Not only can R# not keep up with my typing speed, I have to stop, wait for R# to catch up, and press "escape" before pressing the space key after a tag name, or the equals key after an attribute. If I forget, or I press "escape" too soon, or even if I wait too long after pressing "escape" to continue typing, R# hoses my code.

For example, I type:
<asp:textBox id="myName" runat="server" text='<%# Bind("Name") %>' />

With R#6, I get:
<asp:TextBox ID="myName" runat="server" text="'<%# Bind("Name")%>'" />
(Note the extra quotes, which produce a compile-time error.)

21 comments

I was about to post the same request but I had to wait for my validation email to create an account.

This behavior is EXTREMELY annoying. Right now the only way to get around this is to disable R# intellisense which defeats a major purpose for using R# in the first place.

0

I'm also having performance issues where ReSharper cannot keep up with my typing speed. http://devnet.jetbrains.net/message/5308690#5308690

0

Typing speed is a big problem. It causes a lot of friction for me. I also do not like the big intellisense blobs when I am inside an html tag. They slow things down and cover up too much text behind them. I am not sure if R# or VS is doing this. There's enough annoying stuff going on inside an aspx page, I feel I want everyone out of my area and just want a plain color coded text editor. R# often shows red bars in an aspx page when there's no code or a problem.

Maybe a global flag to switch R# off in aspx pages is helpful.

0

lol yes, it actually is really bad, I was wondering why sometimes it played up and added "" after my attributes. I just attempted to quickly type:
<input type="submit" />

and received output as:
 

<input type="button"submit" class="forgot-username"blah" />


This is *really* bad and I think they need someone who types quick at JetBrains to attempt writing some form tags in a .cshtml and then when it all functions, release the fix :)

Constantly having half-baked intellisense creeping more and more into my day to day activities in Visual Studio is really starting to aggrevate me, I *LOVE* ReSharper, but if these things don't get fixed, (or at least with granuluar control over what can be turned on and off, such as DAMN annoying partner tag completion <div></div>) I might need to uninstall also... or at least turn all Intellisense off which is just silly.

Graham
0

Oh man, this was just typing at average speed without stopping:

 

<form method="GET"post" action="_Layout.cshtml"@Url.Action("post")>
    <input type="button"text name=""blah"/>
    <input type="button"submit" value=""test" style=""width="200px;height:500px;" />/>
</form>
  
Anyway I won't go on, we've identified there is a problem (also I have a fairly quick machine, Core 2 Duo, 4GB Ram, 64bit Win 7..).
0

I've turned off ReSharper intellisense for the moment but it's still a little slow. Expectially when editing the "id" attribute of an HTML element. However I want to turn on the ReSharper intellisense.

I hope we get some kind of feedback that they are working on this.

0

Richard, people tell me that ReSharper does not insert quotes after = sign. Please check Visual Studio options at Tools | Options -> Text editor | HTML | Formatting | Insert attribute value quotes when typing. If it's turned on, please turn off.
We'll look into problem with upper/lower case.

0

Graham, cannot reproduce. Please tell me what Visual Studio options do you have in Tools | Options -> Text editor | HTML on Formatting and Miscellaneous pages and whether you have plugins other than ReSharper installed.

0

Dmitri,

Both VS options are turned off ("insert attribute value quotes when typing" and "when formatting").Options.png

I open an aspx page and type: <asp:textbox id=

The result is: <asp:TextBox ID="" (with the cursor between the quotes)
localhost_63552 - Microsoft Visual Studio.png
Let me know if I've missed something.

0

Do you have other VS plugins installed?

0

I can reproduce this, so I'm not sure why you can't.

In VS2010, open a blank page, and type (exactly, including the quotes):
<input type="submit" />

The result is:

<input type="button"submit" class="failureNotification"blah" />/>
0

I do, but I can't see anything obvious which would cause this behaviour:

  • Entity Framework Power Tools CTP1
  • Find Results Tweak
  • NuGet Package Manager
  • Process Template Editor
  • Productivity Power Tools
  • SQL Server Compact Toolbox
  • tangible T4 Editor
  • Visual Studio Color Theme Editor
  • Visual Studio PerfWatson
  • VSCommands 2010
  • WIT Designer


I'll install the trial version on a clean machine with no other plugins and let you know the results.

0

OK, I've just tried on a computer with no other extensions installed, and I get exactly the same behaviour.

0

Isn't the partner tag completion a setting in VS under Tools | Options | Text Editor | HTML | Formatting | "Auto insert close tag"? It's not R# that's doing that (I tested by changing the setting in VS).

0

I tried to edit my post above but the link doesn't work correctly (in IE or FF).

I posted too soon -- R# is adding the closing tag also -- my apologies.

0

Got it - my settings were different. Thanks for reporting, will try to fix soon

0

Thanks for looking at this Dmitry.

I have attached a screenshot of my options dialog for where you asked.

I have just turned off all ReSharper options I could think were remotely relevant, in Options->Editor but that made no difference, seems they are probably related all to server side code and not HTML.

However playing around with the options in the HTML->Formatting area you mentioned was interesting, as William pointed out, these two options seem to be ignored, both partner tags and double quotes still get added.

Also, on trying to solve the typing speed issue, after unticking them both, in attempt to lessen the load on the engine to fix the problem, closing my .cshtml and reopening the tag formatting prob still exists:
 

<input type="hidden"text" class="ui-accordion"blah" value=""10">/>


Just to clarify, I am talking about two different issues:
  1. Issue when typing too quickly with all the partner completion and intellisense popping up the text gets muddled (so it needs to wait or do it in order or something) (seems you have already created a YouTrack for this)
  2. Auto partner tags and auto partner double quotes on/off seems to be ignored by ReSharper when you adjust the setting in the HTML->Formatting area


On number 2, it seems by suspending ReSharper, the two tag and double quote rules seem to be honored properly, the closing </div> is added only when the second option is ticked by VS, but then not added if it's unticked. So it must definitely be ReSharper somehow overriding them and forcefully performing tag and double quote completion anyway.

Graham



Attachment(s):
html-options.jpg
0

Graham, thanks for looking into this. I'll try to solve those problems in the next ReSharper minor release. But I'm most troubled by issue with slow typing speed with ReSharper. This is a problem that we still cannot reproduce. Could you (or anybody else experiencing the same problem) please capture a performance snapshot of this scenario by following the instructions at http://tinyurl.com/6xgxpw5 and upload it to ftp://ftp.intellij.net/.uploads/, and then write the file name here? Please note that we need snapshot for typing only, so please give Visual Studio&ReSharper some time after loading the solution, type something (there could be some additional delays for first intellisense) and start snapshot for next typing only after that. Thank you!

0

Hi Dmitry,

I have posted a response directly on the bug (http://youtrack.jetbrains.net/issue/RSRP-273813) and attached two videos.  I made sure ReSharper was fully loaded and tested the typing a few times before recording the video. Best of luck narrowing down a solution.
Graham

0

Please sign in to leave a comment.