How to debug into WFC code?

Hi,

I can load symbols for WFC (e.g. System.ServiceModel.dll), but when I go-to-declaration on a type (e.g. System.ServiceModel.Channels.CommunicationObject) I only get all the signatures but no method bodies.

Whereas when I do the same on e.g. Boolean then I get the source code and everything.

Some output from the Output window:

PdbNavigator: Downloader: http://referencesource.microsoft.com/symbols::System.ServiceModel.dll::777C2A759E5C43209DF14AA2C265160D1 -> NotFound (cached)

PdbNavigator: Downloader: http://srv.symbolsource.org/pdb/Public::System.ServiceModel.dll::777C2A759E5C43209DF14AA2C265160D1 -> NotFound (cached)

PdbNavigator: Downloader: http://msdl.microsoft.com/download/symbols::System.ServiceModel.dll::777C2A759E5C43209DF14AA2C265160D1 -> Ok (cached)

PdbNavigator: No debugging information found on symbol servers for System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

PdbNavigator: Searching for 'System.Boolean' type sources in C:\Users\chrishd\AppData\Local\RefSrcSymbols\mscorlib.pdb\E47AF49130474776AF6C5994C50088421\mscorlib.pdb

PdbNavigator: Downloader: http://referencesource.microsoft.com/source/.NET_3.5_sp1_redist/50727.3053/DEVDIV/depot/DevDiv/releases/whidbey/netfxsp/ndp/clr/src/BCL/System/Boolean.cs/1/Boolean.cs -> ok, 9,37 KB


I'm using VS2010, Resharper 6.0, and the ServiceModel assembly is C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.ServiceModel\v4.0_4.0.0.0__b77a5c561934e089\System.ServiceModel.dll.


Any ideas?

Thanks!

Christian


Please sign in to leave a comment.