Resharper Doesn't Support VS2012 Dark Theme w/Color Identifiers?

Pretty straightforward question-- it seems like Resharper's color identifiers feature works great with the VS2012 "Light" theme, but when you switch it to "Dark", no joy.

Anyone else notice this? Any plans to fix this?

I don't want to call everyone who uses the light theme crazy.. but... they're crazy :)

8 comments
Comment actions Permalink

Hello Nicholas,

It should work fine for built-in VS 2012 Dark color scheme. Could you please provide a screenshot of what's happeing in your case, as well as exact VS and R# version numbers?

Thank you in advance!

0
Comment actions Permalink

Alex,

They work, but they obviously were not designed for the dark theme:

Capture.PNG

(see the bright purple)

I know you can set your own colors and stuff, but it's a hassle, and it would be great if Resharper just came with some "dark" presets out of the box.

0
Comment actions Permalink

Hi Nicholas,

This color is a by-design color, and it seems fine to me, since it reads greatly on the dark background.
As you mentioned, you may change this color in "Tools | Options | Environment | Fonts and Colors" dialog. Also, we would like to hear your suggestion regarding this color - what would you prefer?

Thank you in advance.

0
Comment actions Permalink

The one minor issue I've noticed with the dark theme is that the error
squiggles and warning highlights are invisible when the current line is
highlighted using the default dark gray background color.

"Alex Berezoutsky"  wrote in message
news:3460009.67931355816512927.JavaMail.devnet@confluence.jetbrains.net...

Hi Nicholas,

This color is a by-design color, and it seems fine to me, since it reads
greatly on the dark background.
As you mentioned, you may change this color in "Tools | Options |
Environment | Fonts and Colors" dialog. Also, we would like to hear your
suggestion regarding this color - what would you prefer?

Thank you in advance.

---
Original message URL: http://devnet.jetbrains.net/message/5474343#5474343

0
Comment actions Permalink

Hi Greg,

It is a known Visual Studio issue. To workaround it, please turn off VS 'Tools | Options | Text Editor | General | Highlight current line" option.
If you wish to have the current line highliting, you may use ReSharper's option for this in the "ReSharper | Options | Environment | Editor" dialog (note that you need to reopen the documents to have the line highlinghting there).

Thanks.

0
Comment actions Permalink

I am having a similar problem. I know that to root cause is that I originally overwrote the Resharper color settings, but now I cannot get it do switch back. I have tried uninstall/reinstall and resetting the deaults in both the R# options and the VS Fonts and Colors options. The Light theme looks back to normal but the R# colors do not seem to change when switching between Light and Dark themes.



Attachment(s):
2013-01-28_1525.png
2013-01-28_1522.png
0
Comment actions Permalink

try importing this settings (attachment)

i have default R# color settings



Attachment(s):
for jimmy.vssettings.zip
0
Comment actions Permalink

thank you, however it had no effect. the dark settings still look the same. :|

0

Please sign in to leave a comment.