VS2005 SP2 ASP.NET problem with ReSharper 7.1.1 C#

Hi,

I'm new to the ReSharper party but loving it so far. However I have got one major problem with is so fundamental that I think the problem must be me rather than ReSharper.

I have a ASP.NET 2 Web project and in each page there are numerous 'red' issues in the aspx.cs file.

  1. In the using directive System.Data I get 'Cannot resolve symbol Data'. This also occurs for System.Web
  2. This means that the bulk of the code beind is also bright red as it uses classes form the assemblies mentioned above
  3. Oddly string is recognised, but string.IsNullOrEmpty cannot be resolved
  4. The unresolved symbols means that intellisense is useless


[Edit: added image to show issue]
Resharper.png

Also in the aspx file many of the gridview tags such as Columns, asp:BoundField, HeaderStyle and ItemStyle cannot be resolved

I should add that the project compiles and the sites runs without issue.

Can anyone assist me please?

Chris

3 comments
Comment actions Permalink

Hello Chris,

1. Do you actually have the reference added to your project?
2. Does it affect every single solution, even a new asp.net application?

Please lte me know.
Thank you.

0
Comment actions Permalink

Thanks for your response. I tried creating a new project and didn't have the same issue. That was when I realized that my existing project didn't actually have a References area. I came to the conclusion that my project file must have got corrupted, possibly in it's transition from being an early prototype.

I have created a new project in it's place and added all my existing files and everthing is hunky dory.

Thanks again,

Chris

0
Comment actions Permalink

Hi Chris,

Well, seems like ReSharper was correct about 'cannot resolve symbol', then :-) Nice to hear that the issue is now solved for you!

Thanks!

0

Please sign in to leave a comment.