Preventing intellisense item selection with space key ?

Hello,

Here is an example of what I consider a very boring behaviour with Resharper.
Currently, when I type 'Or' (a somewhat usual VB .Net operator !), the Resharper intellisense proposes and preselects "OrderedEnumerableRowCollection (Of )".
Then when I type a space, which is usual after an 'Or', it replaces my 'Or'  by this f***ing selection. Sure I'm always glad with this behaviour !

I want intellisense to propose me a list of possible elements and to preselect what seems adequate, but I also want to insert it in my code only when I type a tab or enter, not when I type a space.
I went through the Intelisense configuration (Resharper options) and keyboard configuration (VS options), but I didn't find anywhere an option to change this.
Sure I forget something.

Currently, in order to avoid this problem, I have disabled the item preselection in the Resharper intellisense option. But it is not what I want.
Is there any way to get what I need ?

Thanks.

2 comments
Comment actions Permalink

did you try to deselect "Include keywords in completion list" in the "Completion behavior" section? I do not remember if this was also a R# 7 option, but in R# 8 EAP you can select if you want to complete on space for every supported language in the "Completing Characters" section.

Regards
Klaus

0
Comment actions Permalink

What a stupid girl I am !

THERE IS a completing characters section with a 'complete with space' checkbox !

Don't know why I didn't want to see it.

Surely to get a nice answer...


Thanks Klaus !


0

Please sign in to leave a comment.