Unit tests are "Pending"

Unit tests will no longer run in Unit Test Sessions. Not sure why this problem is happening, was working in 7.1.1 and VS2012 CTP3 just last week. But might be related to installing VS2012 CTP4, and the trying 7.2.2 to fix the problem.


Hello Stig,

It is a known issue with Update 2 CTP4 for VS2012. Please use CTP3 with ReSharper 7.1.2 for using MSTest for now.
We apologize for the inconvenience.

Thank you!

Same here with CTP 4 and 7.1.2Any idea when this will be solved ?  :-(

Hello Fernando,

Currently, we are testing ReSharper 7.1.3 bugfix update for this issue and will publish it as soon as it is ready.
Sorry for the inconvneience for now.


Thanks Alex,I'll be waiting for this.Regards.

Just a heads up that "Update 2" has RTM'd... is there an EAP release for 7.1.3?


I have just installed the release version of Resharper
JetBrains ReSharper 7.1.2   C# Edition build 7.1.2000.1478 on 2013-02-18T22:08:04

My project contains 3 small MSTest unit tests. When I execute the Resharper runner  it shows Pending for all. VS own test runner has no problem.
How can I get Resharper to execute correctly?



This is a known issue with respect to the latest update of Visual Studio... The next release of ReSharper should address this issue... (7.1.3) we're all just waiting. ;)


Ok, but we are waiting from a month ago (in this thread) for this to be solved.

When we will have next resharper/dotcover release ?


Jonas solution to upgrade Resharper to that specific version solved my issue. Thx a lot!


There's no such thing as a stupid question.
But there are alot of inquistive idiots.

Speaking of which... what is CTP?


CTP = Community Technology Preview, though update 2 has been released.


I believe I'm using the latest versions of Visual Studio and Resharper (11.0.60610.1 and 2.0.2000.2660) but I am still seeing this error - could this be a regression or is there something else I should try?

Many thanks,

EDIT: oops, actually Visual Studio wasn't checking for updates as I thought it was so I was missing a bunch - I've now the latest VS2012 Update 4 RC and this has fixed the issue.


Please sign in to leave a comment.