Resharper Inspect Code does not respect configured Solution Wide Analysis settings. Why?

I noticed the xml reports being generated by inspeccode.exe had more issues than what was showing using "Find Code Issues" inside Visual Studio, but wasn't sure why. Today I realized it is because solution wide analysis is being run by the tool even though the setting is set to disabled on the solution.

Is this intended behavior? The tool already respects other settings from shared .DotSettings files, but this one has a explicit switch to disable it on the command line.

Ideally, it would be possible to override this setting of course (if for instance I would like to force analysis on or off regardless of what is configured for the solution) but I'd like it for the tool to respect my settings by default because I'm running it on the build server.

Have you guys thought about that? I suppose it should be an easy addition and to me it just makes a lot of sense.

Please forgive me if this is just some misunderstanding on my part and it is possible to make it use the solution settings, but I failed to see how I could do that.

Juliano

1 comment
Comment actions Permalink

Hi Juliano!

Yes, it's intended behavior.
Seems, most of people run InspectCode for gettings SWEA analyses, but during regular work in VS many people have it disabled, since it consumes a lot of resources.
So, default behavior is different for InspectCode and ReSharper. You can explicitly save SWEA ON/OFF settings to solution level settings and then InspectCode will use them.
http://confluence.jetbrains.com/display/NETCOM/Introducing+InspectCode#IntroducingInspectCode-Settings

0

Please sign in to leave a comment.