ReSharper VB 8.2.0.2160 - XAML design time issues with Telerik?

I'm runing VS 2012 Ultimate with ReSharper 8.2 and I'm having VERY strange issues that are not consistent.

Example:
1.  Open VS 2012 Project
2.  Open Silverlight 5 XAML in design time
3.  Wait a 5-10 seconds everything appears to load correctly ... then about 5 seconds later (I'm doing nothing), I'll get "bogus" error message about like

"This feature requires service 'Microsoft.Windows.Design.Services.ValueTranslationService' to be present, but it could not be located."


or

"Error 13 [A]Telerik.Windows.Controls.RadRadioButton cannot be cast to [B]Telerik.Windows.Controls.RadRadioButton. Type A originates from 'Telerik.Windows.Controls, Version=2014.1.331.1050, Culture=neutral, PublicKeyToken=5803cfa389c90ce7' in the context 'LoadNeither' at location 'C:\Users\Rob\AppData\Local\Microsoft\VisualStudio\11.0\Designer\ShadowCache\fw5z3p4g.0qy\jkovl4id.ayz\Telerik.Windows.Controls.dll'. Type B originates from 'Telerik.Windows.Controls, Version=2014.1.331.1050, Culture=neutral, PublicKeyToken=5803cfa389c90ce7' in the context 'LoadFrom' at location 'C:\Program Files (x86)\Telerik\UI for Silverlight Q1 2014\Binaries\Silverlight\Telerik.Windows.Controls.dll'. ..."

or

"Error 12  [Line: 0 Position: 0]"


This is ALL at design time.  My application compiles and executes fine.  Also, if I exit VS 2012, come back in the very same XAML file shows no errors at design time ... this problem appears to be random and NOTHING is changed in the XAML.  I've search wide and far but have found NO solution.  I'm about to uninstall ReSharper to see if the problem is solved.


Is there a known compatibility problem with Telerik, ReSharper, and/or NuGet packages from Microsoft?

Thanks, Rob.

Please sign in to leave a comment.