"Include keywords in completion" is broken.

I'm using Resharper 9 Update 1 in Visual Studio 2015 Preview, and I really want to be able to type the "else" keyword and press Enter and have it go to the next line. I turned off the "else" template and code snippet, but now the keyword itself shows up in the auto-completion list. There is a Resharper setting in Intellisense -> Completion Settings called "Include Keywords in completion" and "Only those that are at least X characters long" but these settings don't seem to do anything. Changing the value to 5 or unchecking "include keywords" makes no difference; "else" still shows up as a keyword, with the gold key icon next to it in the auto-completion list.

Please sign in to leave a comment.