ReSharper Command Line Tool: Cannot resolve symbol 'System'

Hello,

When I run analysis using ReSharper Command Line Tool I get lots of false errors in the generated xml such as Cannot resolve symbol 'System'. When I analyze the same solution from visual studio I don't get those errors. The solution compiles and runs ok.

Command line tools version: JetBrains Inspect Code 9.0 Update 1

Visual studio resharper version:
JetBrains ReSharper 8.1 Full Edition
Build 8.1.23.546 on 2013-12-11T23:30:52

I tried clearing cashes but it didn't help.

4 comments
Comment actions Permalink

Can anyone help with this one?

0
Comment actions Permalink

I have the same problem, there is now a "sea of red" for all the errors that Resharper displays. If I turn off Resharper, all the problems disappear.

JetBrains ReSharper Platform 6 Build 6.0.20141219.120158 on 2014-12-19 12:56:02Z
JetBrains ReSharper 9.0 Update 1 Build 9.0.20141219.130142 on 2014-12-19 13:12:31Z

 

0
Comment actions Permalink

Also having the same problem.

 

We have a number of Dll's in a dependencies folder, we inspection is run through visual studio everything is fine. but when "Inspectcode.exe" runs on the build server it throws up thousands of errors saying "cannot resolve symbol" for all the dll's.

The dependencies folder is committed and included in the repository and if I open up the solution on the build server and run the inspection that runs through fine also. so this only occurs from the inspectcode.exe

 

any ideas

0
Comment actions Permalink

We got this error when we wiped the workspace on our build server. Turns out the the code inspector needs the symbol files from the build in order to analyse the symbol usage in the source code. We swapped the order of our debug build and code inspection so that the build runs first, and the problem was resolved.

0

Please sign in to leave a comment.