Is intellisense broken in v9?

When I type in "ByVal" (VB.NET) it automatically converst that to "ProxyElement.BypassOnLocalValues" -- is a bug or is there some way I can work around this problem?

Unfortunately because of this issue ReSharper is actually increase my work load rather than reducing it.

Cheers, Rob.

9 comments
Comment actions Permalink

Same problem here. Wanting to enter "true" and you start typing "tr" and the list comes up with everything "Tr" even though it you are typing in lower case, you almost have to type the whole word out. It seams to NOT look at the case in what you are typing in.(See attached for more examples) Version 8 sensed the variable types much better.



Attachment(s):
ResharperV9 Intellesense.pdf
0
Comment actions Permalink

i had similar problems even if i disabled keyword expansion until i disabled the intellisense filter.

Regards
Klaus

0
Comment actions Permalink

The VB keyword is "True" and not "true". VB itself is infact case insensitive but R# always completes to the correct syntax. So if you explicitely want to write "true" you have to type all characters or disable keyword completion. But i agree with you and Rob that intellisense in R# 9 is a bit clumsy. Best you can do is to disable the intellisense filters. Then you get the old R# 8 behavior which is much more intuitive (at least for me).

Regards
Klaus

0
Comment actions Permalink

I am using it in C#.

0
Comment actions Permalink

Hello Klaus,

  Could you please specify a use case where you reproduced ByVal issue in ReSharper 9.x?

Thanks!

0
Comment actions Permalink

Hi Alexander,

i try to reproduce the problem in a small solution. It is reproducible if you omit the keyword Sub or Function while typing. So if i type

Public Test(ByVal

i get no intellisense popup and when i press Ctrl-Space "ByVal" is replaced by "ProxyElement.BypassOnLocalValues".

If i type

Public Sub Test(ByVal

or

Public Function(ByVal

the Action "Press Tab to expand ByVal parameter template" is displayed and when i press Ctrl-Space the correct intellisense lookup is displayed.

Hope this helps.

Regards
Klaus

0
Comment actions Permalink

Here is the fix that worked for me, given by customer support:

In order solve this problem you should perform the following steps:

1. Close all instances of Visual Studio

2. Locate the %APPDATA%\JetBrains\Shared\vAny\GlobalSettingsStorage.DotSettings file
3. Add the following line to that file (within <wpf:ResourceDictionary ... > tag):

<s:Int64 x:Key="/Default/CodeEditing/Intellisense/GlobalPreferences/CSharpPreferences/LocalsPreferenceOrder/@EntryValue">300</s:Int64>

4. Save the file and start Visual Studio

0
Comment actions Permalink

I agree something is a bit dodgy at the moment.

I am on VS2013 Pro & R#9 using only C#

I see occasional Intelesence failure , ie no list box shows
Ocassional missing parameters
File Structure fails to show the current edit file (see other post)

There is no obvious pattern , so its a tough one to repro. An IDE restart fixes until the next time

I also have addins...(OK Tools Junky !!)

OzCode
SQL Prompt
.Net Demon
Codesmith

Only OzCode is newish, the rest have been part of my set up for years

Is there anything could be interfering ?

Mike

0
Comment actions Permalink

Hello,

Don't know much of IntelliSense details, but Settings are designed to work
on the fly, i.e. you change that and all instances'd get the news as soon
as you activate the VS window.
;)


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

Please sign in to leave a comment.