How can I keep ReSharper IntelliSense enabled after cleaning my working copy?

I frequently run "git clean -xdf" to remove ignored and untracked files from my local Git working copy. After doing so, my IntelliSense setting (ReSharper Options > Environment > IntelliSense > General) immediately changes from "ReSharper" to "Visual Studio" and I stop getting the autocomplete pop-ups when I type a ".".

My main concern is that I frequently have to go back into ReSharper options to re-enable IntelliSense every time I have cleaned my working copy. Is there no way to ensure ReSharper IntelliSense remains enabled after cleaning?

I tried changing General > Caches > "Store solution caches in" to "User local settings folder", thinking that this would cause any relevant files to be stored elsewhere and not be affected by cleaning my working copy, however this is not the case. After cleaning, I can see the setting has changed back to storing the cache in "Solution folder".

I'm currently using Visual Studio 2013 with ReSharper Ultimate 2015.1.1 (9.1.1).

2 comments
Comment actions Permalink

Do you have a .sln.dotSettings file that sits next to your main solution? These are the shared team settings for ReSharper. It's possible that you've set to use the VS intellisense, and it's saved to the solution level settings. If you've then changed it in settings again, it might be saving in .sln.dotSettings.user (this is the user overrides. You need to explicitly say to override shared settings). When you do a clean, the .user file will be removed (you're supposed to commit .dotSettings and ignore *.user) and ReSharper reverts back to the VS intellisense. To make it affect the team shared settings, edit the value in the options dialog and then use the "Save To" button to select the team shared layer.

0
Comment actions Permalink

That was it, our team shared settings had IntelliSense disabled which explains the issue. Thanks!

0

Please sign in to leave a comment.