Resharper Version 10 Intellisense is way too slow (unusable)

I am completely unable to perform my job today because of the recent upgrade from Resharper 9.2 to 10.  The intellisense takes 15 seconds to show up with suggestions.

I am downloading Version 9.2 to reinstall, but the download is going to take 1.5 hours or more.

8 comments
Comment actions Permalink

Same thing happened for me. VS would totally lock up on Intellisense and when making any changes to any file. I reverted back to 9.2 to and every works fine again. Very disappointed by these performance regression : (

1
Comment actions Permalink

Hello Jeff,

Is it a web application (Razor or WebForm)?

Thanks!

0
Comment actions Permalink

Hello Alexander,

i have the same problem and i am using a MVC Razor application.
In general there are some bugs with MVC...

However i dont have this problem with a WinForms application.

Hope this information helps.

0
Comment actions Permalink

Hello Dave,

  Thanks for the reply.

  There are several performance issues for Razor:
  - https://youtrack.jetbrains.com/issue/RSRP-450428
  - https://youtrack.jetbrains.com/issue/RSRP-450394
  - https://youtrack.jetbrains.com/issue/RSRP-450331
  - https://youtrack.jetbrains.com/issue/RSRP-450441

  We are working on them right now.

  My apologies for the inconvenience.

Thanks!

0
Comment actions Permalink

Hello Alexander
I have the same issue with version 10, the project is web forms in VB.
Slowdown is not constantly present. The most evident is in the condition part of a if... then clause it takes ten to fifteen seconds to show the autocomplete of a local property in the class. First part of the condition is fast enough but as soon as I type = and start typing the name of another variable there's a lag of a couple of seconds between what I type and what VS shows.
Between "then" and "end if" performance is similar to version 9, so everything is fine.

I've also seen slowdowns on the aspx editor when inserting new controls, the autocomplete with the runat="server" is so slow that's unusable.

1
Comment actions Permalink

Alexander,

This is a C# Web application.  Not Razor, not MVC.

Also, how can I turn off receiving emails for each post posted to this forum?  It's getting annoying.

1
Comment actions Permalink

Hello Jeff,

Please please follow the instructions described in the item 7 here http://resharper-support.jetbrains.com/entries/24083148-Visual-Studio-with-ReSharper-is-slow to collect a snapshot and send it to us.

As for notifications: Profile | Edit preferences | Email Notifications Preferences.

-1
Comment actions Permalink

Hello Igor,

Please please follow the instructions described in the item 7 here http://resharper-support.jetbrains.com/entries/24083148-Visual-Studio-with-ReSharper-is-slow to collect a snapshot and send it to us.

Thanks!

-1

Please sign in to leave a comment.