Extensions Manager doesn't aggregate any other Packages source


since hours, I tried to deploy some pluggins and I followed some instructions like this post: https://devnet.jetbrains.com/message/5521563#5521563
Each time I re-open the Extensions Manager, it displays only the 20 pluggins from  https://resharper-plugins.jetbrains.com/api/v2/curated-feeds/Wave_v2.0/
I tried many format like c:\,,, or file://... or my own Package Repository http://.... but no way.

I'm missing something or does version 9.1 didn't act like older versions ?

Bye the way, all documentation + samples seem to target v. 8.2 ...

Thanks for any help.


Comment actions Permalink

ReSharper 9.1 still supports multiple package sources. You can add them and edit them in ReSharper → Options → Extension Manager. It just needs to be a normal file path: C:\temp or whatever, and make sure the item is ticked. If the package exists in the folder and it's not showing up in the Extension Manager list, make sure that the package name has a "." in it, e.g. "Matt.AwesomeExtension", and that it's got a package dependency on Wave 2.0. Also, if the package is pre-release, you have to explicitly allow pre-releases in ReSharper → Options → Extension Manager.

Comment actions Permalink


I think I just discovered the issue.


I tested this morning the same configuration in 4 computers at work.

On 3 is installed latest version of R#


The local plugins are not displayed (path: C:\Temp\NuGet)


On the 4th pc, version 9.0 is installed and the plugins are displayed correctly from same path



Hope it may help to figure what's the issue.



Comment actions Permalink

Just another info,

I just tried to install the version EAP 9.1.1 RC on my VS2013 Premium update4

   \\serverpath in Company

   No pluggins displayed

-Close VS2013
-ReInstallation of ReSharperAndToolsPacked01Update1.exe
-Open VS2013
-Open Resharper -> Extensions Manager
-My custom plugin is displayed

Comment actions Permalink

OK, I'm getting a little confused as to the combinations of what works and what doesn't. As I understand it:

  • ReSharper 9.0 - using "c:\temp\nuget" works.
  • ReSharper 9.1 - using "c:\temp\nuget" does not work. Using "\\server\folder" works
  • ReSharper 9.1.1 - using "\\server\folder" does not work

Is this right?

I've tried both folder types on all three versions, and it's working fine for me, so ReSharper does support these folder types. The only thing I haven't been able to check is a unc path for a server that requires authentication. I'm not sure if that's supported - i.e. I don't think the extension manager prompts for credentials.

Note that if you're using 9.0, the extension package needs to have a dependency on Wave 1.0. For 9.1 and 9.1.1, the extension package needs to have a dependency on Wave 2.0. If these dependencies aren't right, the package isn't displayed.
Comment actions Permalink

Hey Matt,

I finally get it.

Thanks to you ;)

Your sentence:  "on Wave 1.0. For 9.1 and 9.1.1"

I downloaded one the plugin from your repository ("resharper-plugins.jetbrains.com/packages/")  JLebosquain.EnhancedTooltip.2.3.1.nupkg

I copied it in my local c:\Temp\Nuget folder and I didn't see it with R# version 9.0.1

I changed the JLebosquain.EnhancedTooltip.2.3.1.nuspec wave version to 1.0 and save it.

Now, I can see it in Extensions manager.

I just installed latest R# 2015 9.1.1 rc and I can't see it.

I changed back the JLebosquain.EnhancedTooltip.2.3.1.nuspec wave version to 2.0 and save it.

Now, I can see it in Extensions manager.

So, I just made the same modifications on my plugin and I can see it now.


Sorry for the bother

I didn't get this wave think.

Ps. Hope you'll update the developer documentation with the latest api. All lot of stuff are still for old versions.


Kind regards



Please sign in to leave a comment.