Modifying tab-stop to conform to setting.

It would be nice if R# could modify the file to conform to the tabs-spaces
setting of VS.NET for tab-stops.

If it already does this, please tell me what the setting is...

- Richard


3 comments
Comment actions Permalink

I should have added: "... when using the 'Reformat Code' function."

- rb

"G. Richard Bellamy" <rbellamy@nospam.nospam> wrote in message
news:e0q4hq$cnb$1@is.intellij.net...

It would be nice if R# could modify the file to conform to the tabs-spaces
setting of VS.NET for tab-stops.

>

If it already does this, please tell me what the setting is...

>

- Richard



0
Comment actions Permalink

Hi,

actually ReSharper should use VS's settings for Tab size and 'Insert spaces' option when reformatting files (those settings are located on the Text Editor|C# page). Doesn't it work for you? Thanks.

0
Comment actions Permalink

I am having the same problem. Our company policy is to set the VS options as

Tab size = 8
Indent size = 3
Keep tabs = On

With these settings, VS auto-indents the code with a mixture of Tabs and Spaces. For example:

1st level indentation = 3 spaces
2nd level indentation = 6 spaces
3rd level indentation = 1 Tab + 1 space (visually appears as an indentation of 9)
4th level indentation = 1 Tab + 4 spaces (visually appears as an indentation of 12)
..etc..

When I use R# to reformat the code, it uses one Tab per indent level. So the result is:

1st level = 1 Tab (visually appears as an indentation of 8)
2nd level = 2 Tabs (visually appears as an indentation of 16)
...etc...

This is clearly not we want to get. Is there a way to make Resharper indent the code the sameway VS does?

Thanks,
TK

0

Please sign in to leave a comment.