#241 Can you reopen 19537 ?

Not sure why this issue has been marked obsolete? I've been getting this
error often with build 241, with different projects / code files. Comments
has been added to the stack traces posted in the tracker.

This bug, plus 24860 (which is marked as fixed now) are very annoying :(


Regards,

Dag Christensen



6 comments
Comment actions Permalink

Hello Dag,

done. Could you please tell us what VS settings with regard to file editing
do you have?
In particular, is the project you're experiencing this problem in is under
source control? Is editing
of read-only files allowed in VS (it is controlled by an option)? Thanks
in advance.


Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Not sure why this issue has been marked obsolete? I've been getting
this error often with build 241, with different projects / code files.
Comments has been added to the stack traces posted in the tracker.

This bug, plus 24860 (which is marked as fixed now) are very annoying
:(

Regards,

Dag Christensen



0
Comment actions Permalink


I'm not sure which file editing settings you mean?

All my source files are under source control (Borland StarTeam). The setting
"Allow editing of read-only files; warn when attempt to save" is enabled,
but my files are checked out (read only flag cleared) or new (not added to
source control yet), so this should not be the problem. I have not seen this
problem in earlier versions (I don't remember if the previous version I used
was 238 or 239),

I created an empty console application (not source controlled), and so far
haven't seen the problem there.

Regards,

Dag



"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
news:c8a894d9174cab8c84260f17740af@news.intellij.net...

Hello Dag,

>

done. Could you please tell us what VS settings with regard to file
editing do you have?
In particular, is the project you're experiencing this problem in is under
source control? Is editing
of read-only files allowed in VS (it is controlled by an option)? Thanks
in advance.

>
>

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>> Not sure why this issue has been marked obsolete? I've been getting
>> this error often with build 241, with different projects / code files.
>> Comments has been added to the stack traces posted in the tracker.
>>
>> This bug, plus 24860 (which is marked as fixed now) are very annoying
>> :(
>>
>> Regards,
>>
>> Dag Christensen
>>
>



0
Comment actions Permalink

Hello Dag,

the problem is almost definitely in source control. Is there an observable
pattern in how 19537 occurs - i.e. does it happen in all files or is there
a sequence of steps causing this problem?
Thanks.

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

I'm not sure which file editing settings you mean?

All my source files are under source control (Borland StarTeam). The
setting "Allow editing of read-only files; warn when attempt to save"
is enabled, but my files are checked out (read only flag cleared) or
new (not added to source control yet), so this should not be the
problem. I have not seen this problem in earlier versions (I don't
remember if the previous version I used was 238 or 239),

I created an empty console application (not source controlled), and so
far haven't seen the problem there.

Regards,

Dag

"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
news:c8a894d9174cab8c84260f17740af@news.intellij.net...

>> Hello Dag,
>>
>> done. Could you please tell us what VS settings with regard to file
>> editing do you have?
>> In particular, is the project you're experiencing this problem in is
>> under
>> source control? Is editing
>> of read-only files allowed in VS (it is controlled by an option)?
>> Thanks
>> in advance.
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>> Not sure why this issue has been marked obsolete? I've been getting
>>> this error often with build 241, with different projects / code
>>> files. Comments has been added to the stack traces posted in the
>>> tracker.
>>>
>>> This bug, plus 24860 (which is marked as fixed now) are very
>>> annoying :(
>>>
>>> Regards,
>>>
>>> Dag Christensen
>>>


0
Comment actions Permalink

Just managed to reproduce it two times in a row:

1. Fresh Visual Studio 2005 instance
2. Created a new console project (not under source control)
3. Added a windows form and a pushbutton
4. Double-click the pushbutton to open its onclick event
5. Type "string s;" and press Enter

Exception message popped up

Regards,

Dag


"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
news:c8a894d9174d298c842657244bdf7@news.intellij.net...

Hello Dag,

>

the problem is almost definitely in source control. Is there an observable
pattern in how 19537 occurs - i.e. does it happen in all files or is there
a sequence of steps causing this problem?
Thanks.

>

Regards,
Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>> I'm not sure which file editing settings you mean?
>>
>> All my source files are under source control (Borland StarTeam). The
>> setting "Allow editing of read-only files; warn when attempt to save"
>> is enabled, but my files are checked out (read only flag cleared) or
>> new (not added to source control yet), so this should not be the
>> problem. I have not seen this problem in earlier versions (I don't
>> remember if the previous version I used was 238 or 239),
>>
>> I created an empty console application (not source controlled), and so
>> far haven't seen the problem there.
>>
>> Regards,
>>
>> Dag
>>
>> "Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
>> news:c8a894d9174cab8c84260f17740af@news.intellij.net...
>>
>>> Hello Dag,
>>>
>>> done. Could you please tell us what VS settings with regard to file
>>> editing do you have?
>>> In particular, is the project you're experiencing this problem in is
>>> under
>>> source control? Is editing
>>> of read-only files allowed in VS (it is controlled by an option)?
>>> Thanks
>>> in advance.
>>> Regards,
>>> Dmitry Shaporenkov
>>> JetBrains, Inc
>>> http://www.jetbrains.com
>>> "Develop with pleasure!"
>>>> Not sure why this issue has been marked obsolete? I've been getting
>>>> this error often with build 241, with different projects / code
>>>> files. Comments has been added to the stack traces posted in the
>>>> tracker.
>>>>
>>>> This bug, plus 24860 (which is marked as fixed now) are very
>>>> annoying :(
>>>>
>>>> Regards,
>>>>
>>>> Dag Christensen
>>>>
>



0
Comment actions Permalink

Some extra details:

When I create a new Windows project, add a button to the autogenerated form
and repeat steps 4 and 5 below I'm don't get any exception.

If I add a second form to the Windows project, add a button and eventhandler
as described below I get the exception.


I then created a new console application and added a new class file, moved
to the "{" in the code below and pressed enter. The cursor moved to column 1
on the "}" line:

class Class1
{| <-- cursor was here before Enter
}

class Class1
{

| } <-- Cursor moved here after Enter

I pressed the up arrow key (which moved the cursor to the end/column 9 of
the blank line where I expected it to be in the first place), typed "void
foobar() {" and pressed Enter. This caused the same exception. ReSharper did
not add the closing parenthesis when I typed the opening "(", I had to type
this myself.

Regards,

Dag

"Dag Christensen" <no_reply@jetbrains.com> wrote in message
news:e3smu7$t9o$1@is.intellij.net...

Just managed to reproduce it two times in a row:

>

1. Fresh Visual Studio 2005 instance
2. Created a new console project (not under source control)
3. Added a windows form and a pushbutton
4. Double-click the pushbutton to open its onclick event
5. Type "string s;" and press Enter

>

Exception message popped up

>

Regards,

>

Dag

>
>

"Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
news:c8a894d9174d298c842657244bdf7@news.intellij.net...

>> Hello Dag,
>>
>> the problem is almost definitely in source control. Is there an
>> observable pattern in how 19537 occurs - i.e. does it happen in all files
>> or is there a sequence of steps causing this problem?
>> Thanks.
>>
>> Regards,
>> Dmitry Shaporenkov
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>
>>> I'm not sure which file editing settings you mean?
>>>
>>> All my source files are under source control (Borland StarTeam). The
>>> setting "Allow editing of read-only files; warn when attempt to save"
>>> is enabled, but my files are checked out (read only flag cleared) or
>>> new (not added to source control yet), so this should not be the
>>> problem. I have not seen this problem in earlier versions (I don't
>>> remember if the previous version I used was 238 or 239),
>>>
>>> I created an empty console application (not source controlled), and so
>>> far haven't seen the problem there.
>>>
>>> Regards,
>>>
>>> Dag
>>>
>>> "Dmitry Shaporenkov (JetBrains)" <dsha@jetbrains.com> wrote in message
>>> news:c8a894d9174cab8c84260f17740af@news.intellij.net...
>>>
>>>> Hello Dag,
>>>>
>>>> done. Could you please tell us what VS settings with regard to file
>>>> editing do you have?
>>>> In particular, is the project you're experiencing this problem in is
>>>> under
>>>> source control? Is editing
>>>> of read-only files allowed in VS (it is controlled by an option)?
>>>> Thanks
>>>> in advance.
>>>> Regards,
>>>> Dmitry Shaporenkov
>>>> JetBrains, Inc
>>>> http://www.jetbrains.com
>>>> "Develop with pleasure!"
>>>>> Not sure why this issue has been marked obsolete? I've been getting
>>>>> this error often with build 241, with different projects / code
>>>>> files. Comments has been added to the stack traces posted in the
>>>>> tracker.
>>>>>
>>>>> This bug, plus 24860 (which is marked as fixed now) are very
>>>>> annoying :(
>>>>>
>>>>> Regards,
>>>>>
>>>>> Dag Christensen
>>>>>
>>
>>
>



0
Comment actions Permalink

I'm not seeing this in 242 so far.

Build 241 was installed without uninstalling 238 first (since the release
notes doesn't mention it's required anymore?). I uninstalled 241 before
installing 242.

Regards,

Dag


0

Please sign in to leave a comment.