Error detection and intellisense does not work for AJAX tags when using master pages

Hi - I am using build 301.

R# still highlights the new AJAX tags as bugs when the aspx page is using
a master page. The tags are ok when used in an aspx page not using master
pages.

By the way, will your build also work with AJAX Beta 2?

Cheers
Thomas


14 comments
Comment actions Permalink

Thomas,

R

  1. still highlights the new AJAX tags as bugs when the aspx page is using

a master page. The tags are ok when used in an aspx page not using master
pages.

Hmm, I'll check it tomorrow.

By the way, will your build also work with AJAX Beta 2?

I tried a couple of simple solutions with Beta 2, they were ok.

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Thomas,

I've created simple master page and a web form, that uses it with AJAX.
Everything worked as expected.
Maybe, there is something peculiar in your case? If you could send us sample
solution, that illustrates your problem, it would be great.

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Hi Sergey - thats strange.

My master page is fairly simple. I only have one contentplaceholder in my
master page.

I'll give it look when I get home.

Thomas

Hello Sergey,

Thomas,

I've created simple master page and a web form, that uses it with
AJAX.
Everything worked as expected.
Maybe, there is something peculiar in your case? If you could send us
sample
solution, that illustrates your problem, it would be great.



0
Comment actions Permalink

Hi again - I do not know what is wrong. :)

I have tried removing an adding the entries in the web.config for the Pages
section - the ones with the asp: prefix to no avail.

However, briefly the problem was gone - however closing and opening re-introduced
the problem.

The tags are underlined with red, the tags for AJAX are not present in the
intellisense pop-up. However, R# is still showing a green in the upper right
corner of my aspx file!?

Thomas

Hi Sergey - thats strange.

My master page is fairly simple. I only have one contentplaceholder in
my master page.

I'll give it look when I get home.

Thomas

Hello Sergey,

>> Thomas,
>>
>> I've created simple master page and a web form, that uses it with
>> AJAX.
>> Everything worked as expected.
>> Maybe, there is something peculiar in your case? If you could send us
>> sample
>> solution, that illustrates your problem, it would be great.


0
Comment actions Permalink

Thomas,

It's dead strange. It might be something wrong with caches. Does it change
anything if you type enter at the very beginning of ASPX file?

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Hi Sergey - there is no change. :(

I have tried to flushing the cache from the options dialog, opening and reopening,
hitting enter and seeing the color indicator go from green to the grey color
and back again to green. The AJAX tags are still underlined with red.

I have pasted the versioning information about my VS2005. There are some
hotfixes as well.

Cheers
Thomas

-


Microsoft Visual Studio 2005
Version 8.0.50727.51 (QFE.050727-5100)
Microsoft .NET Framework
Version 2.0.50727

Installed Edition: Enterprise

Microsoft Visual Basic 2005
Microsoft Visual Basic 2005

Microsoft Visual C# 2005
Microsoft Visual C# 2005

Microsoft Visual C++ 2005
Microsoft Visual C++ 2005

Microsoft Visual J# 2005
Microsoft Visual J# 2005

Microsoft Visual Studio Tools for Office
Microsoft Visual Studio Tools for the Microsoft Office System

Microsoft Visual Web Developer 2005
Microsoft Visual Web Developer 2005

Microsoft Web Application Projects 2005
Microsoft Web Application Projects 2005
Version 8.0.60504.00

Visual Studio 2005 Team Edition for Developers
Microsoft Visual Studio 2005 Team Edition for Software Developers

Visual Studio 2005 Team Explorer
Microsoft Visual Studio 2005 Team Explorer

Crystal Reports
Crystal Reports for Visual Studio 2005


Hotfix for Microsoft Visual Studio 2005 Team Edition for Software Developers
- ENU (KB910275)
This Hotfix is for Microsoft Visual Studio 2005 Team Edition for Software
Developers - ENU. \n
If you later install a more recent service pack, this Hotfix will be uninstalled
automatically. \n
For more information, visit http://support.microsoft.com/kb/910275

ReSharper 2.5 (build #301)
ReSharper add-in for Microsoft Visual Studio. For more information about
ReSharper, see the ReSharper website at http://www.jetbrains.com/resharper.
Copyright (c) 2003-2006 JetBrains, Inc

SQL Server Analysis Services
Microsoft SQL Server Analysis Services Designer
Version 9.00.1399.00

SQL Server Integration Services
Microsoft SQL Server Integration Services Designer
Version 9.00.1399.00

SQL Server Reporting Services
Microsoft SQL Server Reporting Services Designers
Version 9.00.1399.00

Update for Microsoft Visual Studio 2005 Team Edition for Software Developers
- ENU (KB915364)
This Update is for Microsoft Visual Studio 2005 Team Edition for Software
Developers - ENU. \n
If you later install a more recent service pack, this Update will be uninstalled
automatically. \n
For more information, visit http://support.microsoft.com/kb/915364

Thomas,

It's dead strange. It might be something wrong with caches. Does it
change anything if you type enter at the very beginning of ASPX file?



0
Comment actions Permalink

Thomas Koch schrieb:

I have tried to flushing the cache from the options dialog, opening and
reopening, hitting enter and seeing the color indicator go from green to
the grey color and back again to green. The AJAX tags are still
underlined with red.


Having the same Problem in 2.02 (online in Pages based on Masterpages).
I thought it was a Visual Studio Problem.

Regards

Ablert

0
Comment actions Permalink

Albert,

could You send me an example of such a problem? Probably, the way You're
using the pages differs from that I typically use and the problem lies there
--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0
Comment actions Permalink

Sergey V. Coox (JetBrains) schrieb:

Albert,

could You send me an example of such a problem? Probably, the way You're
using the pages differs from that I typically use and the problem lies there


No Problem.

.master

Untitled Page

.aspx

Tags bearbeiten


Interne Bezeichnung:
Angezeigter Tagname:
Sichtbar für:


Interne Bezeichnung:
Angezeigter Tagname:
Sichtbar für:

]]>

0
Comment actions Permalink

Sergey V. Coox (JetBrains) schrieb:

could You send me an example of such a problem? Probably, the way You're
using the pages differs from that I typically use and the problem lies there


Something happens :)

I open the .aspx File, every AJAX Tag was underlined as an error.

Now if i changed the validation schema of the page, shortly after that
every error disappears and intellisense is also up an running (not before).

It doesn't matter which validation schema is active in visual studio, on
opening an .aspx file brings the error, after switching to an other
schema everything works as expected.

Maybe Thomas can verify this.

Regards

Albert


0
Comment actions Permalink

Hi - I have tried modifying the xmlns property of the head tag in the master
file, but alas, to no avail. The red lines are still there.

However, I noticed that Albert had the ]]> tag in his master
page. When I inserted a scriptmanager tag in my master page i did not get
any red lines for that tag.

However, I cannot make the red lines go away in the aspx file regardless
of the value in the xmlns property.

What is interesting though, is that the I have full intellisense for all
the asp: tags in the master file - AJAX tags included, but the intellisense
in the aspx file does not know the new AJAX tags.

Hope this helps.
Thomas

Sergey V. Coox (JetBrains) schrieb:

>> could You send me an example of such a problem? Probably, the way
>> You're using the pages differs from that I typically use and the
>> problem lies there
>>

Something happens :)

I open the .aspx File, every AJAX Tag was underlined as an error.

Now if i changed the validation schema of the page, shortly after that
every error disappears and intellisense is also up an running (not
before).

It doesn't matter which validation schema is active in visual studio,
on opening an .aspx file brings the error, after switching to an other
schema everything works as expected.

Maybe Thomas can verify this.

Regards

Albert



0
Comment actions Permalink

Thomas Koch schrieb:

Hi - I have tried modifying the xmlns property of the head tag in the
master file, but alas, to no avail. The red lines are still there.


This is a Visual Studio Problem. ReSharper don't show any error.

However, I noticed that Albert had the <ScriptManager ..> tag in his


That's documented in the AJAX Documentation :)

master page. When I inserted a scriptmanager tag in my master page i did
not get any red lines for that tag.


Me too.

Hope this helps.


http://forums.asp.net/thread/1463401.aspx
http://forums.asp.net/thread/1462184.aspx
http://forums.asp.net/thread/1435560.aspx

It's problem with the asp: prefix. Maybe SP1 or a later Version of MS
AJAX will help.

Regards

Albert

0
Comment actions Permalink

Ah, thanks for reporting that. :)

Thomas


Thomas Koch schrieb:

>> Hi - I have tried modifying the xmlns property of the head tag in the
>> master file, but alas, to no avail. The red lines are still there.
>>

This is a Visual Studio Problem. ReSharper don't show any error.

>> However, I noticed that Albert had the tag in his >>]]>

That's documented in the AJAX Documentation :)

>> master page. When I inserted a scriptmanager tag in my master page i
>> did not get any red lines for that tag.
>>

Me too.

>> Hope this helps.
>>

http://forums.asp.net/thread/1463401.aspx
http://forums.asp.net/thread/1462184.aspx
http://forums.asp.net/thread/1435560.aspx
It's problem with the asp: prefix. Maybe SP1 or a later Version of MS
AJAX will help.

Regards

Albert



0

Please sign in to leave a comment.