Any updates on 3.0 support?

I've just had to go ahead and uninstall R#, and I'm depressed about it.
It's not even fun to be a programmer without my R#. I know that MS shocked
the world when they release 2008 prior to the scheduled date, and now JB is
behind the 8-ball... but do I have to remind you that I'm depressed? ;)
Anyway, looking forward to a beta R# w/ 3.0 support soon.

3 comments
Comment actions Permalink

Hello Peretz,

Some information can be found in my blog post: http://resharper.blogspot.com/2007/11/resharper-and-visual-studio-2008.html

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


PR> I've just had to go ahead and uninstall R#, and I'm depressed about
PR> it. It's not even fun to be a programmer without my R#. I know that
PR> MS shocked the world when they release 2008 prior to the scheduled
PR> date, and now JB is behind the 8-ball... but do I have to remind you
PR> that I'm depressed? ;) Anyway, looking forward to a beta R# w/ 3.0
PR> support soon.
PR>


0
Comment actions Permalink

Could a feature be added to the R# addin, such that it is automatically
disabled on projects target a version of the framework higher than 2.x?
Personally I'd prefer an update in which it detects "unsupported" features
in a per file basis (Or some less than entire project demarcation) and
"disables" itself only in that file. Maybe even let us place a specific
comment at the top of the file so that R# ignores the entire file?

Just random ideas...

bR


"Ilya Ryzhenkov" <orangy@jetbrains.com> wrote in message
news:76a2bd0b14aa3c8ca0566de054eaa@news.intellij.net...

Hello Peretz,

>

Some information can be found in my blog post:
http://resharper.blogspot.com/2007/11/resharper-and-visual-studio-2008.html

>

Sincerely,
Ilya Ryzhenkov

>

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>

PR> I've just had to go ahead and uninstall R#, and I'm depressed about
PR> it. It's not even fun to be a programmer without my R#. I know that
PR> MS shocked the world when they release 2008 prior to the scheduled
PR> date, and now JB is behind the 8-ball... but do I have to remind you
PR> that I'm depressed? ;) Anyway, looking forward to a beta R# w/ 3.0
PR> support soon.
PR>


0
Comment actions Permalink

Hello,

Could a feature be added to the R# addin, such that it is
automatically disabled on projects target a version of the framework
higher than 2.x?


Would it be any better than the existing AltTA shortcut?

Personally I'd prefer an update in which it detects
"unsupported" features in a per file basis (Or some less than entire
project demarcation) and "disables" itself only in that file.


And what should happen to the usages of the symbols in this file? Or to the
usages of its symbols in other files? No, that needs to be per-project, at
the least. That way we can ignore the source code and feed on the DLL output,
as if it's a compiled reference. With all the due consequences, like in VS
built-in cross-language intellisense.

Oh, and why bother, we will have an EAP pretty soon :) In something like
a month, I hope.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

Please sign in to leave a comment.