VS2008 shuts down when opening a web app

I am trying to open a web (not one I produced, I am trying to finish it for someone else). But when I open the solution, Visual Studio 2008 just shuts down with no error message. If I uninstall Resharper, it does open (and everything compiles correctly). Here is the log:

I am attaching the log file.



Attachment(s):
JetBrainsLog.2008-03-23T18-59-42.devenv#5596.log
7 comments

Also, something else to mention. Disabling Resharper (via the AddIn Manager) does not seem help the situation.

So, the only way to work on this solution is to uninstall Resharper.

0

I have experienced this with some previous R# 4.0 builds. I have not tried
to open a web solution with the latest release, but all I can suggest is
uninstalling and rolling back to previous versions until you find one that
works. A word of warning though--I did this several times, eventually
rolling back to a version I knew worked with web application projects, and
VS2008 would still shut down. It seems in some cases a reboot is also
required after a rollback. I hope this helps.

Cheers,
Mike

"Rob Cannon" <rob@cannonsoftware.com> wrote in message
news:25361795.33251206534041271.JavaMail.jive@app4.labs.intellij.net...

Also, something else to mention. Disabling Resharper (via the AddIn
Manager) does not seem help the situation.

>

So, the only way to work on this solution is to uninstall Resharper.


0

I have the same problem, and don't think rolling back will help, since I experienced this with some of the first EAP builds released. For whatever reason, deleting/recreating the sln file sometimes helps, but the problem always eventually returns.

0

Hello Brad,

What build of ReSharper do you use?

Sincerely,
Ilya Ryzhenkov

JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


B> I have the same problem, and don't think rolling back will help,
B> since I experienced this with some of the first EAP builds released.
B> For whatever reason, deleting/recreating the sln file sometimes
B> helps, but the problem always eventually returns.
B>


0

I have resharper uninstalled now, for obvious reasons. I know I had the problem in 743,755 and 763. I think I had it in other builds, I am sure I tried one before 743. I know I have not had a build without the problem (or I would never have unistalled or upgraded).

0

I am able to prevent the problem by removing the resharper directory from my addin path.

Unfortunately, I cannot use this to turn resharper on and off for different projects. The installer uses an addin path with an extra backslash, and the GUI won't let me enter it that way. Entering the path normally does not load resharper. Without this path, Resharper does nothing except create a menu with everything grayed out and the only way to put the path back is unistalling/reinstalling

0

Hello Rob,

yesterday we discovered a very similar problem - VS with ReSharper crashed
when trying to open the DotNetNuke web site. We investigated this problem
using WinDBG and it appears that it has something
to do with NGen'ing of System.Web.Extension assemblies. More precisely, the
fatal exception happens after the following line in the WinDBG output:

CLR:C:\Windows\assembly\GAC_MSIL\System.Web.Extensions\3.5.0.0__31bf3856ad364e35\System.Web.Extensions.dll)
Rejecting native image because dependency C:\Windows\assembly\GAC_MSIL\System.Core\3.5.0.0__b77a5c561934e089\System.Core.dll
is not native

Could you please try to attach WinDBG to VS before opening the web site,
wait for the exception to happen (use 'Go Unhandled Exception' feature of
the debugger) and check if the above line
appears in the output?

As a workaround for the problem, when we removed the System.Web.Extensions
subfolder from the C:\WINDOWS\assembly\NativeImages_v2.0.50727_32\ folder
(thus effectively making System.Web.Extensions
not native-generated), the problem disappeared and DotNetNuke opens just
fine.


Dmitry Shaporenkov
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


I am trying to open a web (not one I produced, I am trying to finish
it for someone else). But when I open the solution, Visual Studio
2008 just shuts down with no error message. If I uninstall Resharper,
it does open (and everything compiles correctly). Here is the log:

I am attaching the log file.



0

Please sign in to leave a comment.