ASP.Net bug in 811: ID="

Using 4.0 build 811 EAP in VS2008
Asp website with a single default.aspx, and master page.
aspx in source view.
The page looks like this:
<asp:Content ID="Content1" ContentPlaceHolderID="ContentPlaceHolder1" Runat="Server">

</asp:Content>
I type within the content...
<asp:Button runat="server" ID="

On the open quote, resharper shows the namespace tooltip: "use system.web.ui.webcontrols.content (Alt+Enter)"
(The position is bad too- right over the cursor). Clicking it does nothing, as there's nothing to do.

The reference is whatever the following asp tag is, so this suggests Button:
<asp:Content ID="Content1" ContentPlaceHolderID="ContentPlaceHolder1" Runat="Server">
<asp:Button runat="server" ID="
<asp:Button runat="server" ID="x"/>
</asp:Content>

It doesn't seem to occur on "normal" pages without master pages, and it's only on the ID attribute.

1 comment
Comment actions Permalink

Martin,

I've created an issue for this
http://www.jetbrains.net/jira/browse/RSRP-70557
I agree we should parse it more accurately, but currently I've no idea how
to cope with it. Once you type in something after quote the popup goes away.

--
Sergey V. Coox
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"
"martin" <mwilley@cereus.be> wrote in message
news:11612183.44761212158038722.JavaMail.jive@app4.labs.intellij.net...

Using 4.0 build 811 EAP in VS2008
Asp website with a single default.aspx, and master page.
aspx in source view.
The page looks like this:
<asp:Content ID="Content1" ContentPlaceHolderID="ContentPlaceHolder1"
Runat="Server">

>

</asp:Content>
I type within the content...
<asp:Button runat="server" ID="

>

On the open quote, resharper shows the namespace tooltip: "use
system.web.ui.webcontrols.content (Alt+Enter)"
(The position is bad too- right over the cursor). Clicking it does
nothing, as there's nothing to do.

>

The reference is whatever the following asp tag is, so this suggests
Button:
<asp:Content ID="Content1" ContentPlaceHolderID="ContentPlaceHolder1"
Runat="Server">
<asp:Button runat="server" ID="
<asp:Button runat="server" ID="x"/>
</asp:Content>

>

It doesn't seem to occur on "normal" pages without master pages, and it's
only on the ID attribute.



0

Please sign in to leave a comment.