775 - "Waiting for parse to complete..."

When editing an XSL or XML file, the editor freezes with this message in the
status bar:

Waiting for parse to complete...

The CPU is basically idle.

Once that happens, the only way out is to terminate VS.NET from the Task
Manager.

Glen


7 comments
Comment actions Permalink

Hello,

There were a couple builds with such behavior in editing XML-based files.
Please try more recent nightly builds.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

I can confirm that this is happening in 805.

In my case, it occurred when adding a closing angle bracket to the opening of a tag within a Regionerate layout xml file. I'd love to send JetBrains the file, but the changes were lost. :(

Additional details: XP SP2, VS 2008 + ASP.net hotfix roll-up. Solution loaded. Regionerate xml file from outside the solution loaded in an editor window while three other solution source files were also open. XML file would have been valid after the closing angle bracket was typed, prompting the editor to add the closing element automatically.

Edited by: Jeremy Gray on May 22, 2008 12:26 AM

0
Comment actions Permalink

As a quick update: I have now had this happen three or four times since my last post. From what I recall, most if not all hangs immediately followed the typing of the closing angle bracket on an opening element.

0
Comment actions Permalink

Hello,

As a quick update: I have now had this happen three or four times
since my last post. From what I recall, most if not all hangs
immediately followed the typing of the closing angle bracket on an
opening element.


We were able to reproduce this in-house (not repeatably, though), and the
case points out to a good old deadlock in the managed VS XML parser codebase.
It's our code that helps it happen, anyway, so we'll think something up before
the final release. Thanks for reporting the issue.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

Awesome. Thanks for the update!

0
Comment actions Permalink

Can anyone confirm whether this has been fixed in the final release please?
Thanks

0
Comment actions Permalink

Hello,

Can anyone confirm whether this has been fixed in the final release
please?


I applied the fix before the release, and so far it seems to work OK.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0

Please sign in to leave a comment.