Cannot uninstall R# 5 EAP

Good evening,

I just wanted to uninstall a slightly older (Oct 30th) build of the 5.x eap.. but for some reason it always throws an error (msi error code 2329) and reverts back. I looked whether I can uninstall it from within VS 2010 (it's the beta2) under its extension manager, but r# doesn't show up in there at all :-/

How can I get rid of this version now? I can't update to a newer one aswell since the upgrade process also tries uninstalling.. which.. again.. fails.



When I have this problem, I just install a more recent build, and that installer takes care of the previous version uninstall.

I've also specifically had problems running dotTrace 4.0 w/ R# 5 on both VS2010 and VS2008.


Well in my case installing a newer version does not cut it... the installer of the new version tries to uninstall but fails just like the manual attempt.. same error message et al.


Do you have dotTrace v4.0 installed? I had to uninstall that first.

If not, try running from a command line: msiexec /i ReSharperSetup.5.0.15xx.xx.msi /l* %temp%\failed_resharper_5_install.log

The error should be in there, and usually points to what needs to be done to resolve it.


Oh man.. I still had an old/orphan copy of R# 4.5 installed. Uninstalling that first and trying to uninstall 5.0 thereafter worked. I just couldn't do the same the other way around. Meh.



Please sign in to leave a comment.