No Colors in VS 2010 (Win7 64-bit)

Thus far, I have been running nearly every new Resharper 5 build on two different machines:

1. A 32-bit Vista desktop (this also has Resharper 4.5 installed)

2. A 64-bit Win 7 laptop (this has never had any previous versions of ReSharper installed).

I am currently at build #1645 on both

The Vista desktop is displaying the Resharper color scheme just fine.

The Win7 laptop is not. It only shows the default VS2010 colors. No matter what I try, I cannot get the Resharper color scheme to apply on this second machine.

Any ideas or help on this?

8 comments
Comment actions Permalink

Hello,

Just to confirm — what happens if you close all of the documents and reopen
them?

Is this still the case with the most recent nightly build (2010-03-29)?


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

Yes, absolutely still hapenning, up and including build 1651.

Closing and reopening documents, rebooting the computer, even un-installing and re-installing ReSharper doesn't work. VS2010 default colors only.

Again, this is a 64-bit Windows laptop, and it's never had VS2008 or any Resharper licenses installed on it.

The colors on my 32-bit Vista desktop are totally fine. I do have VS2008 on that one, as well as a license for Resharper 4.5.

0
Comment actions Permalink

Hello,

64bit is OK, we'd massively use such a config for development.

Is your VS 2010 version a compatible one (RC or newer)?

Is the "highlight identifiers" R# option on? Are all of the ReSharper features,
but for the editor colors, running normally? Are the errors highlighted in
red by ReSharper (warnings, suggestions, etc)? Does the "highlight current
line" option have any effect (after you close all files and reopen them)?
Is the Error Stripe visible on the right-hand side of the text view, with
error/warning marks on it?

Are any other VS 2010 extensions working (especially considering any editor
visual effects)?


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

Options > Code Inspections > Settings > Enable Code Analysis > Color Identifiers.

I have no idea how I missed this checkbox!  ::: facepalm :::

How embarrasing. That was the problem. Which I guess is good news for you... (one less thing to fix!)

Thanks very much for pointing me in the right direction.

0
Comment actions Permalink

Should this option be enabled by default? I'm just curious since I noticed
it is disabled by default in 1649 and others.

"Serge Baltic" <baltic@intellij.net> wrote in message
news:dc0986bf151d398cc9dd87e6b2955@news.intellij.net...

Hello,

>

64bit is OK, we'd massively use such a config for development.

>

Is your VS 2010 version a compatible one (RC or newer)?

>

Is the "highlight identifiers" R# option on? Are all of the ReSharper
features, but for the editor colors, running normally? Are the errors
highlighted in red by ReSharper (warnings, suggestions, etc)? Does the
"highlight current line" option have any effect (after you close all files
and reopen them)? Is the Error Stripe visible on the right-hand side of
the text view, with error/warning marks on it?

>

Are any other VS 2010 extensions working (especially considering any
editor visual effects)?

>


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”

>

0
Comment actions Permalink

Definitely should be enabled by default. It has been in previous versions, which is probably why I had no idea where to look for the option.

0
Comment actions Permalink

Hello,

I think it's off by default — like, to be less intrusive, I don't know.


Serge Baltic
JetBrains, Inc — http://www.jetbrains.com
“Develop with pleasure!”


0
Comment actions Permalink

Hello Serge,

Hello,

I think it's off by default - like, to be less intrusive, I don't
know.


Yes. It's off by default since ages.

Regards

Albert


0

Please sign in to leave a comment.